Rambo 1.4 reflash


I’m looking for a way to reflash my board (Rambo 1.4).
Now I have the Marlin firmware (Marlin_V13DP_Rambo_2.0.7.2_e31f1a5-src).
This firmware is working. However, I would like to make corrections about the K-factor (Linear Advance).
I see that the X-loader cannot upload a new firmware.
Arduino makes attempts, but writes an error {‘void u8g_spiSend_sw_AVR_mode_0(uint8_t)’}.

How can I upload a new firmware in this case?

Thanks in {linear} advance.

Marlin grew too big for the Arduino IDE some time ago. You can use PlatformIO.


Well yes.
I tried to use the PlatformIO, but something went wrong during the installation.
Now I have an invalid shortcut from “Visual studio” only.
For this reason, I decided to try Arduino.

It seems to me that there must be some simple way to remove the old firmware from the board.

Can I somehow remove the old firmware and reflash a new one through the X-loader?

You don’t have to remove the old version. XLoader writes over the old version when it installs. But XLoader requires a binary version of the firmware. The Marlin firmware in text format that you can edit to change settings must be compiled to a binary before XLoader can flash the firmware. The only tool I’m aware of right now that can compile Marlin is Visual Studio Code and PlatformIO. There are likely other tools that can compile the code, but they will come with their own complexities and likely without instructions. And if you get VC/PlatformIO to compile the code, it will also flash that code without needing to go through XLoader.

My suggestion is to start by doing an uninstalling of Visual Studio Code and starting over with the instructions that Ryan provides.

As a side note, Visual Studio Code is not the same thing as Visual Studio. I know the naming is confusing.

1 Like

Partly correct… Marlin blows up the Arduino IDE on Windows due to the command line growing too long. It still works on Linux, and presumably on Mac. This can basically be treated as the Arduino IDE not working for the majority of people though.

I would re-try the platformio installation. Yank it all out, and start from a fresh install of VS Code, and be sure that you can get into that. Note that VS Code is not Visual Studio. Then install the plugin from VS Code. (Check the V1 docs page. I’m sure that it can be fixed up.)

1 Like

I am very grateful for your explanations.
However, my computer that is connected to the machine is controlled by Windows 7.
Nevertheless, I found the installation file “VSCode” for this old version of Windows and performed the installation.
Now I have a compilation problem. I opened the firmware folder, but I don’t find any compilation options (or buttons) there in the left corner.

I am somewhat discouraged.

It looks like you don’t have platformio installed in vscode.

1 Like

It’s me again with my questions.
Thanks to your advice, I have made progress in solving my task. Now I have a PlatformIO and I have the ability to compile the program. Thank you again.

Now I have a problem with the M900 in the code. I studied the issue and found that my original firmware does not recognize the M900 for some reason.
I corrected the file according to the recommendations.
However, the compiler informed me about the failure:

The file “gcode.cpp” looks like this:

Q: How can I fix the “gcode.cpp” file so that the M900 command compiles and is understandable to the Repetier-host?

The advice where they remove the #if is bad advice. You should instead be changing only the configuration and configuration_adv.h files.

Find LIN_ADVANCE in those files and enable it.

1 Like

Uncomment this line in configuration_adv.h:

//#define LIN_ADVANCE

And revert the code in gcode.c.


I deleted two slashes before the specified line.
If this is a uncommenting, then I did it.

Now the compiler reports this:

Should I delete all slashes at the beginning of all lines in the “Lin_advance” block?

1 Like

What it is telling you is that you need to delete the slashes from this line:

  //#define EXPERIMENTAL_SCURVE // Enable this option to permit S-Curve Acceleration**strong text**

I don’t know anything about the features you are enabling, so I cannot give you any guidance beyond what the compiler is providing.

Thank you for your help.
This topic about reinstalling marlin is solved. I found a new problem about Lin_Advance, but it will be a new topic.