Rambo 1.4, X2 & Y2 steppers not moving

Just finished building my MPCNC. Bought the Rambo 1.4 from V1 so it came with the firmware already preloaded, all the other parts were ordered from Amazon. Eventually I will run dual end tops and have them all wired up but they are currently not plugged into the Rambo, as I have not flashed the dual Endstop firmware.

The issue I am having is that the steppers plugged into E0/E1 (X2/Y2) are not moving at all. Steppers plugged into X1/Y1/Z are all moving correctly. I have tried moving the axis’ from the LCD and repetier host, same issue from both. To rule out bad stepper motors I swapped X2/Y2 motors and plugged them into X1/Y1 spot and they worked correctly. I currently have the belts removed to check if they are working. Set screws on pulleys are tight all around.

-M119 returns X/Y/Z as open

-Fuses are all fine

-Steppers work plugged into X1/Y1

-Power is supplied to the Rambo B/C power inputs from a 350W meanwell PSU

Steppers: https://www.amazon.com/dp/B00QEYADRQ/ref=cm_sw_r_cp_api_i_h8aPDb53KX734

The standard firmware uses x1 and y1 only with the steppers wired in series. Sounds like you are wired for dual endstops but using the standard firmware.

2 Likes

With the dual endstop firmware M119 should return X/X1/Y/Y1/Z, not just X/Y/Z. That’s the quick and dirty way to check you have the right stuff installed.

Makes sense. I’m not a complete newb when it comes to all this. Ive been using 3D printers for 3-4 years now that run on mini-rambo and einsy rambos.

Before I got in too deep I wanted make sure the mpcnc would work without the Endstops that’s why I didn’t flash the firmware that shipped with the Rambo from V1. What I didn’t know is the basic firmware does not use the extra stepper plugs on the rambo board. Since you are supposed to wire them in series with all the X motors going to one and all the Y motors going to another. Now that I know this I will update to the dual endstop firmware and give it another go.

Just be aware that dual endstop firmware only uses the endstops to square the machine before use. Once you have it squared it will stay square until you power everything off and move things manually. You don’t really use it to set home as with a 3D printer, that is done by moving to where you want home to be then sending the G91 X0 Y0 Z0 command. You wouldn’t want to use the home function at that point since it’ll set home based on the machine parameters, not based on the work piece.

The dual endstop firmware works without endstops. The one caveat is that it has softstops on by default. So it is limited to not go into negative X or Y. He does that to avoid crashing into endstops. You can disable those before you flash, or there is an mcode to do it (M122 is sticking in my mind).

Just to be clear so I can benefit from the posts here, the stepper motor wiring for the Rambo v1.4 with the V1 Engineering Firmware is as follows?

X Stepper to X Terminals, Y Stepper to Y Terminals, Z Stepper to Z Terminals, Second X Stepper to X0 and Second Y Stepper to X1 Terminals.

Correct?

Does this clear it up?

https://www.v1engineering.com/auto-square-dual-endstops/

I too am having the same problem.

I purchased the Rambo 1.4 with the dual endstop firmware.

Seems it does not have the firmware installed. When I send the mentioned M119, I get

x_min: triggered

y_min: triggered

z_min: open

So I assume I need to D/L the proper firmware for the dual endstops to the Rambo?

Can I get the proper file and instructions, or even better, the link to how to?

Thanks,

Mike

Go to the link Ryan posted above. About 1/2 way down the page is a link to the firmware page.

Choose which firmware here. Should be “MPCNC_Rambo_T8_16T_LCD_DualEndstop”

Follow instructions here https://www.v1engineering.com/assembly/software/

[attachment file=119072]

1-1.jpg

1 Like

Thanks, Did that no problem, but I have no clue how to D/L the software to the Rambo.

Sorry for my ignorance…

Thanks,

Mike

https://www.v1engineering.com/marlin-firmware/

Step by step instruction found here.

Arduino had a compile error and could not upload

Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

sketch\src\HAL\HAL_AVR\u8g_com_HAL_AVR_sw_spi.cpp:65:20: fatal error: U8glib.h: No such file or directory

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

You’re missing the u8glib library. The instructions Tom posted show how to get that. There are multiple similar ones, so make sure you get the right one.

1 Like

Thank all you guys for all the help!

Up and running with the crown test. Really cool!

Looking forward to the next challenge when I go to wood!

Again THANKS ALOT