Rambo board help

i have a full sized Rambo board. I am really unsure how to get it to work, or how to connect power. I had two wires in the center spot, and had a power light came on. But the motors didn’t sound like they were powered, and using repetitier, I tried to move the motors. I didn’t hear any motor movement.


i have auto set for port, installed the driver, and bought the kit from this site. I tried swapping for the six port connector, thinking maybe it’d spread the power to all three ports. After that I can’t get it to power on again. I hear it enumerate in Windows 10, and see it as “Rambo” under ports.

the Fuse looks ok, but I’m not sure what a blown fuse looks like. I’m worried that I swapped polarity of the power cable (and how are we supposed to know the correct way to hook that up?). It feels like the mini Rambo has decent documentation but the full one didn’t.

also I couldn’t register with this forum using a hotmail address, I had to switch to my work email to get this working (checked junk email but never got verified)


anyway hoping something simple is being missed.

The fuse should register continuity if tested with your multimeter. Sometimes the + and - are written in tiny text ( I need magnification to read them) on the board. Check both sides.

The polarity is marked on the board itself. You need to power the first two ports. I will try to get some more pictures up today for you on the ultimachine boards page found at the bottom of the assembly page.


That’s version 1.1, so potentially yours could be different, but I also saw an Instructables article that showed the same polarity. I believe Ryan is talking about the ones labeled “Motors and Logic” in the picture I linked.

I am going to replace the fuse and see if I can get the lights back on. Regardless, when the power light turned on I had wires in the middle port of the three. I had started with it in the bottom set (motors and logic) (bottom when orienting the board the same as the reprap wiki). With that, the motors weren’t moving. I’ll replace the fuse tonight and try again.

That shouldn’t have popped it. I have done a full reverse polarity on accident, no issues. You need power in both motors and logic ports. As far as I remember the big fuse is only for the heated bed 3rd port, the two smaller white ones are for the other two ports. You can continuity test them.

ok that’s really good to know, though I’m concerned that I haven’t seen the light since doing that. I’ll buy a multimeter tonight (I know, I know…I should have one). I’ll start debugging from that aspect.

The thing is, when the light came on, I didn’t see the motors move. When you say that motor and logic ports need power…that’d be great to have in the instructions (apologies if I missed it).

I attatched the board diagram that seems to line up with what I’m seeing: https://cdn.shopify.com/s/files/1/1223/5992/files/RAMBo-manual-1-3.compressed.pdf?16979196395167232400

From what I may be hitting…perhaps I need to pigtail between motor and logic to get things going? I think that would be the missing step to detail/take photos of. If I get mine working I can donate photos of it to help if that’s useful.

I’m super excited, because I think I’m REALLY close…just need to get past this last thing I think :slight_smile:

I am working on some pictures.

It is the same as the ramps wiring for wiring both ports, power to one and jumpers over or if you have the 30A you just wire to both.

1 Like

Ok got home with a meter…F2 from that diagram looks like it’s popped. Sadly it doesn’t look like they include a spare, so working on finding a source for a new one


If that version is more like yours, then you should connect the power to the logic connector as well as the motor connector.

Basically what both you and Ryan said. :smiley:

1 Like

Thanks guys, I appreciate the help and quick suggestions! I just found the fuses for a dollar on ultimaker, and ordered 3. I’m frustrated I don’t get to see this thing move till they get here, but it’ll give me time to print the flexible chain stuff to clean up the wires I spose. I’ll also get pigtails going…I have the 6amp supply. I’ll try to get photos up once it works, if I can contribute back to the community and save someone else that pain that’d be great. Ryan, I don’t envy you trying to do version control for your tutorials, it seems like you’ve improved this quite a bit as you go along, but then to manage the builds as things get better has to be a full time job.


Heh, your last post wasn’t here until I posted. I just looked at the picture again and noticed the comment about what might blow that fuse. Careful that nothing metallic touches the board and shorts things…


I have no fuses, but I’ve been considering adding some. I’ve had many failures in the 3d-printer world with heated bed or power input connectors and these days I just solder the wires in place instead of using connectors, but fuses would have reduced the damage when they went awry. I haven’t really thought about if my CNC controller is facing a lot of vibration or not.

The last few days have not gone as planned but I have at least got up a few basics for the Rambo. The formatting got messed up. I will try to get to it tonight, if it cooperates.



Ok, so now I’ve temporarily shorted the fuse at F2 just to see if I can get the board back up. I have it booting again! (Yay!) and see debug spew. I’ve put the short jumpers across as the diagram that you uploaded shows (thanks for getting that up!).


I’ve got repetier host up, and can connect and see spew from the board.

I’m going through this doc: https://www.v1engineering.com/repetier-host/

I don’t have the thermistor or resistor on T0…it mentions the ramps board. Is this needed with the Rambo? If so I’ll have to get a resistor next.

Right now when I hit connect, I get:

01:39:10.025 : Printer reset detected - initalizing
01:39:10.025 : start
01:39:10.029 : echo:Marlin 1.1.0-1
01:39:10.029 : echo: Last Updated: 2017-05-04 12:00 | Author: (none, default config)
01:39:10.029 : Compiled: Jan 15 2018
01:39:10.033 : echo: Free Memory: 3418 PlannerBufferBytes: 1296
01:39:10.037 : echo:EEPROM version mismatch (EEPROM=? Marlin=V37)
01:39:10.037 : echo:Hardcoded Default Settings Loaded
01:39:10.038 : echo: G21 ; Units in mm
01:39:10.041 : echo: M149 C ; Units in Celsius
01:39:10.041 : echo:Filament settings: Disabled
01:39:10.041 : echo: M200 D3.00
01:39:10.042 : echo: M200 D0
01:39:10.042 : echo:Steps per unit:
01:39:10.045 : echo: M92 X100.00 Y100.00 Z400.00 E100.00
01:39:10.046 : echo:Maximum feedrates (units/s):
01:39:10.050 : echo: M203 X190.00 Y190.00 Z30.00 E25.00
01:39:10.050 : echo:Maximum Acceleration (units/s2):
01:39:10.054 : echo: M201 X500 Y500 Z35 E10000
01:39:10.054 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
01:39:10.058 : echo: M204 P400.00 R3000.00 T400.00
01:39:10.062 : echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
01:39:10.062 : echo: M205 S0.00 T0.00 B20000 X4.00 Y4.00 Z0.20 E5.00
01:39:10.062 : echo:Home offset:
01:39:10.066 : echo: M206 X0.00 Y0.00 Z0.00
01:39:10.066 : echo:Material heatup parameters:
01:39:10.070 : echo: M145 S0 H196 B62 F0
01:39:10.070 : M145 S1 H240 B110 F0
01:39:10.070 : echo:PID settings:
01:39:10.070 : echo: M301 P17.98 I0.98 D83.62
01:39:15.070 : echo:SD init fail
01:39:15.096 : FIRMWARE_NAME:Marlin 1.1.0-1 (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:MPCNC EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
01:39:15.137 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
01:39:15.154 : echo:DEBUG:INFO,ERRORS
01:39:15.154 : echo:Active Extruder: 0
01:39:15.154 : Begin file list
01:39:15.157 : End file list
01:39:15.198 : echo:DEBUG:IN14,ERRORS
01:39:15.202 : Error:No Checksum with line number, Last Line: 13
01:39:15.202 : Resend: 14
01:39:15.218 : echo:Active Extruder: 0


Then I hit the arrows for x/y/z, and I don’t hear or see any motor movement. When I use the voltmeter, I detect 12 volts off of each pair of screws for the motor, and logic sections of the Rambo board.

Any ideas of what to try next? Could it be the resistor? I don’t even hear the motors kinda tense up like I have other projects.

Did you compile the firmware? One thing that prevented me from moving the machine in one direction was that I had compiled the firmware with normally closed end stops but did not have any end stops attached. Likely not the reason for what you are seeing, but I thought it’s worth mentioning.

Nope. Not on the ramps either. Deleted that part.

I agree with Hubert, What firmware is on your board? Did you buy it from me? What kit did you buy, if you got the Dual endstop kit you have to plug in 4 endstops.

I bought it from you, and selected Rambo. I don’t think I selected dual end stops. I didnt want to flash firmware and add another random thing till I’d asked if there was something else I might be missing. Since I’d gotten it from you I figured it was programmed so was starting from there.

the motors aren’t even humming like they’re trying to move. I’ll check the firmware tonight and try recompiling it

Connect with repetier and type m119 what does it say?

x_min: open

y_min: open

z_min: open


…is that bad?

It means you have the correct firmware.

Can you upload a picture of your board plugged in and wired up please.