Rambo Board not Showing Up on Computer -Solved-

Hello all,


I just got done assembling my MPCNC and can’t seem to get the connection on Repetier. The Rambo board does not show up at all in windows explorer to say that the usb connection is there. Attached is my hookup for my board and the issue screen I am seeing. I followed the tutorials for setting up Repetier but still getting the issue.

I bought all the hardware, motors, and such from Amazon or locally. I bought the series wiring harness and the Rambo board from the site.

Any help here?


Make sure the usb port is correctly selected and the power is on baud rate is 250000. If possible try another usb port. Or show the repetier settings screen.


The only other thing is if you mistakenly powered it backwards, even for a half a second you can pop the little fuse. I mention this for people not using the 6 port plug, the four port can miss the right pins and pop the fuse as well.

I can run the cnc without being hooked up to the computer. I started out with an LCD display then decide a computer would be better to run the cnc with. I only moved around in the x, y and z axes. Didn’t run any code through it yet. I get the green light on the board when the power is on.

Did you install the Arduino IDE? That installs the drivers for the USB port.

1 Like

I’m on windows 10. I installed the Arduino IDE app through the App Store and then also the full desktop download from the website as well. I still wasn’t able to make it work. But I will try the suggestions you and Ryan have given. Thanks in advance.

Won’t work, You need arduino 1.9, and the app store version doesn’t ever seem to work right (of the three people that have tried it in recent memory).

1 Like

Hey Ryan I have installed Arduino 1.8.7 from the Arduino website. The usb drivers and everything else is installed. I have the green light on at the Rambo but still nothing showing up on the computer saying that the board is there. I have tested all the USB ports I have on the computer but still can’t get it to show up. Any ideas here?

All of my other usb devices work fine. Just can’t seem to get the Rambo to work.

Can you try it on another computer?


This will be the second computer I have tried this on. Not sure what else I can do? Reflag the firmware on the board? This doesn’t seem needed bc I can run it through the LCD screen.

Use a different USB cable? Make sure the external power supply is connected and on? Did you check the fuses as suggested above?

If the computer can’t see it, you can’t reflash it. If the arduino software can see it, then it’s not the board.

In the first screen when you try an connect to repetier, it gives the error, follow it to the setting screen, what is there? Screenshot please.

At this point it is either the USB cable or those settings.

Set the speed to 250000bps, it defaults to slower and the board won’t respond unless they match.

Here is a screenshot of the Repetier Host Printer setting screen. I have tried a new usb cord and still nothing shows up on the computer.

Two things, Repetier server needs to get uninstalled, it has caused problems in the past, and manually select your usb port, not auto.


If you want to use Server put it back later but it adds complications.

1 Like

Change the port to something other than auto. I’ve had issues with “auto” working in the past.

I have gotten it to work!! Thanks for all the help and advice. Now I can start some drawing and then hopefully move on to the MP3DP. Thanks again guys!

What was the fix?

I deleted the repetier server like you said. Then I went through the USB ports one by one option wise till it connected. Eventually I found the right one.

1 Like