Rambo stopped working

Hi Ryan,

I finally finished installing the Rambo board. It worked. While going through the menu system a few times and after about 1 hour, the Rambo stopped working. All I get is a blank screen. No information. The screen is on, but no menu. I am disappointed that the board would stop working during normal use. I did not even get to print anything yet. I checked all three fuses. I get 12 volts at all three fuses. Cables have continuity. What do I do now?

Thomas Damato

Does it work with repetier? You assume the control board but I assume the lcd, swap the LCD cables. Where did you get it? What else is plugged in? Pictures?


Your reply went to email.

Unplug the LCD, use the power cable and the USB and try repetier. If that is not working you can check to see if arduino recognizes it. These boards are crazy resilient nothing should be wrong it it worked for a while.

Worst case, reflash it.

Also Take the fuse out and check continuity.

Hi Ryan,

Yes you were right. It turned out to be the Full graphic smart controller and not the Rambo board. Thank you very much for pointing me to the graphic card.