RAMBO X2 (E0) not driving right



I rewired my system for the Dual Endstops. I am on a RAMBO 1.4 from Ryan.

All is working slick except for the output of E0 (AKA X2). Which even stepper is connected to that output, it sorta vibrates and does not move right. The Other 3 X, Y, and Y2 all output quiet smooth movement to the motors.

If I use the X motor into the X2 port, then that motor acts bizzare.

I looked through teh Source code and all teh settings for X match X2 for current and such. Do I have a bumb board? (never used the E0 output till this mod.




Are you using my firmware? Marlin 1 or 2? I did a full test yesterday on the build in my github, confirmed good.



Yes I am using your firmware. I am a big FB see so the entire process I used and results are in several live videos there from today.


including my E0 chatter.


I have now tried all four motors on the E0 output an all 4 motors chatter but they run smooth in their own driver slot.


the only mod I made to your code was to invert the 4 Min endstop polarity as I use active endstops.

Two things to try, swap the cables and swap the steppers. Easy to do with your belts off. See if it follows the driver, the extender, or the stepper. There has only been one board issue so far and it was a mini, chances are pretty good it is something else. Not saying it can’t happen but the other stuff takes two minutes to check.

Which ever firmware it is also try the other as well. Just to rule out a screw up on my part. I am done for the night, I will double check the driver current in the morning. I am not sure I adjusted all of them…or at least I don’t remember checking it yesterday.

No worries.


i did swap all 4 motors. With wires. First thing I tried. Any motor plugged into the E0 output chatters.


in your code block, all 4 motors X, X2, Y, Y2 looked set the same for the 3 settings. 800 ma RMS.


Ill be at it tomorrow as well. :slight_smile:


Using the RAMBo dual endstop T8, 16 tooth

You really need to stop unplugging powered steppers. I have never seen a driver survive that. Does your X1 still work after your video?

If ultimmachine has somehow prevented that from popping a driver I am going to send them a thank you note tomorrow. I know they have prevented back current from basics manual movements but I didn’t think from a powered disconnect.

Yeah… just read that part again… yikes…



X1 has all 4 motors tried hot swap, and back to the X1 motor. Still smooth. So I guess they hardened their board against idiots like me?

So I can’t seem to find the address I need to send the defective RAMBo back to?



The board seems to work 100%, other than the switched endstop logic but I am guessing you did that?

It does?!? With no changes?

im at a loss for that.


yes, I reverse the endstops because I am using active switches that do debouncing and such on the little circuit board, and the use N/O logic.


so dang. I’ll place an order for a kit and you can send mine back in that order.

I ran it on my machine, all steppers have what seems like equal power. I am going to try a separate set of steppes just to be 100%, after the mail run.

1 Like

If you feel it’s OK, then send it back with my KIT order, so I have spares. I just paid for a full RAMBo kit and the works, so I will have extra parts. I am hating this downtime, this system is too much fun. another $300+ to have full spares is worth it :smiley:

Wow a full kit for spares!?!

Double double checked they all work 100%. I have no idea what could have been happening during your tests. Something must be funky on that end.

1 Like

Yes, my way of also thanking you for the project! It’s worth it.



1 Like