Ramp 1.4 - Dual End Stops, Bigger Power Supply ?

Just finished assembling Ramps 1.4 based MPCNC with Dual end stops.

X, Y and Z access seem to work fine if I use them FIRST. This includes auto homing for the X and Y and moving Z up and down.

However, if for example I auto home X then Y or Z may not work properly with one or more of the steppers making a sound like it can’t quite move forward and it does not appear to be moving.

If I unplug, then re-plug and then move either X, Y or Z first then that one seems to work normally.

I’m wondering if its related to the power supply it does say 6A 12 V, but I wonder if the steppers (since there are 5, each connected to its own driver) need more 5 * 1.5A, as 1.5A is the current limit set for each stepper.



No, it doesn’t work that way. Convert everything to Watts if you wanted to compare, but we also do not use the steppers at 100% ever or all the time.

I am not really sure what the issue could be. You do need to home first or they will only move one direction (XY) Z should not care.

1 Like

Thanks for the quick reply.

It always seemed to occur after the Z was used (which seemed to occur even when homing X or Y sometimes) so I disconnected the Z stepper. With the Z stepper disconnected I cannot get it to replicate.

I’ll see if possibly the Z driver is bad or maybe I did not calibrate it properly.

The calibration looked ok at about .7v and changing to a different driver module did not resolve either.

I can move the X and Y, and autohome as much as I want when the Z stepper is not connected. As soon as I connect it then after Z is used I can home X, but then Y fails.

Power off and physically swap drivers.

What I did was to open a new driver package and swap that physically with the one for the Z stepper. Same problem.

I also tried calibrating up to .8v and down to 0.6v but still same problem as well.

Other than homing it works fine? Exactly how are you homing, G28 X Y? My firmware? What does M119 say?

I’m using the LCD to home X and home Y.

I tried swapping the other stepper drivers as well, one at time but no luck there.

I just measured the voltage delivered to the ramps board, it is ~ 12 to 12.5 volts when I home X, which also moves Z, then when I home Y it drops to 7v.

The power supply says it has 12v 6A.





Same issue, it is still either your power supply, Ramps, or arduino. So far you have eliminated the driver, as swapping them changes nothing. Next likely problem is ramps (check for solder blobs and shorts under the black plastic strips), next would be arduino. You can test the power supply but will need a load of some sort.

These issues are very common now with the import boards.

Measured the current, when in the problem state where Y home is failing, current draw was only about ~3A

That sounds really high, that would be 36W, should be ~6w



I swapped out the ramps board, and still had the same problem.

Next I found an old computer power supply and tried that out. With the computer power supply it all seems to work ok.

I measured the total current draw again.

  1. Its starts out around .15A when I turn the machine on.

  2. It jumps up to around 1A when I home X and the Z stepper is moved. I assume they stay energized at this point

  3. It jumps up to around 2A when I home Y. At this point I assume all 5 steppers are energized.

I’ll have to double check my multi meter if you think those are still too high.

Other than that, changing the power supply seems to have resolved the problem.

To answer some of the earlier questions it is your firmware. I checked things out earlier with an M119 and the endstop switches were working ok.

One last thing which I don’t think is related. I’d not wired a Z stop switch since I figured I’d manually set Z instead but it does not look like the firmware will let me do that. I guess I’ll just wire a switch in so that I can use it to manually signal the home for Z.

Yup, have a look at touch plates, or a clip and thin metal.

1 Like

Thanks for the help this can be closed.

What was the issue?