Ramps 1.4 - One stepper not moving


I have some trouble with my Ramps 1.4 board with dual endstop firmware.

I’m using Arduino Mega clone, Ramps 1.4, DRV8825 and Nema 17 84oz. 12v 25A psu. Vref is set to 0,9V and i do have all jumpers under drivers (1/32 step).

Everything works except Y1 stepper wont move. I suspected a faulty driver or stepper, but both do work if i connect them as X1, X2, Y2, Z…

I have no lcd or endstops yet and all movement is done through Repetier Host. No transistors are touching and i have not shorted anything. All drivers except Y1 are getting warm.

Any suggestions?




Pretty sure you need the endstops installed.

1 Like

I can’t think of a software or firmware problem that would cause that. I would look at the botton of the ramps to see if the soldering is done right. Then I would try swapping the ramps board and the arduino.

1 Like

I just tested the Arduino, Analog 6-7 (Y-step, Y-dir) is working when using digitalwrite and LED connected.

Checked connection to stepdriver, SLP/RST is bridged on ramps. Enable pin ok, 10kohm to VCC. GND, VCC, 12v+ is good. Connection between Ramps (measured from stepdriver pins) and Arduino are good.

Could lack of endstops cause this problem?

Thanks! :slight_smile:

Is it Ryan’s dual endstop firmware? He has it set up to only listen to endstops during homing.

Besides, it should affect both sides the same. And the X axis too.

Yes, this one to be specific “Marlin-MPCNC_Ramps_T8_16T_LCD_32step_DualEndstop”. I ordered another Ramps 1.4 just to rule that out :slight_smile:

I just done the crown test a couple of times and found out another problem. It’s missing Z-steps sometimes right at the beginning.

I’m using T8 lead screw with 2mm lead (3200 steps/mm). I think this could be the problem since it has to rotate much more. Should i order another leadscrew or is there any easy fix? Maybe change to 1/16 step instead of 1/32 step on Z?

Thanks! :slight_smile:

That’s the easiest fix. Assuming the high steps/sec is the problem. I thought modern versions of Marlin were actually protecting themselves against that though.

There are two limits here:

  1. The CPU actually has to change the state of the pin 6400 times / mm. If you’re going too fast, it can’t keep up. When it reaches that limit, will it just take a few steps off, or will it know and raise an error, stopping your job?

  2. The drivers are changing current into the coils faster than they can reach the current limit. In this case, the limit is the actual number of turns per second and not the steps/mm. What can happen is that as the motor turns faster, the driver can’t get enough current to get max torque. The motors will skip backwards instead of forwards to reach the next coil. This is where you might be skipping steps. On my machines, it has a distinct sound, like a grinding noise because instead of going forward, it abruptly goes backward 1/200th of a turn. To solve this problem, you can get higher driver voltage (using a 24V power supply) or just go slower. If you change your screw out, you can get higher speed with the same torque, but the torque will be reduced by the mechanical advantage (or lack of it, mechanical disadvantage?).

Either of these two problems are solved by lower Z speeds. It should be easy to change the Z speeds to something like 8mm/s and since the Z rarely goes more than 10mm at once, it doesn’t really affect most jobs.



Thanks a lot for the answer!!

My Z-motor actually makes likea a grinding noise, so that might explain the issue. If i run the crown test a couple of times, the Z=0 point gets higher and higher.

I will try 1/8 or 1/16 step, and i will upgrade to 24V when my PSU arrives and everything else is working. I’m aware that the 5V voltage regulator on Arduino will need an upgrade :slight_smile:

Double check that the lead screw is lubed, that the nut isn’t tight and that you can move easily up and down through the whole range by turning the screw with your finger when the stepper is off.

1 Like

1/8-step on Z-axis solved my problem. I also found the problem on the Ramps board. “Enable” pcb trace to Y1 driver was bad.

I did my first cut tonight in some scrap wood with great success. Thanks for all help :slight_smile: