Ramps 1.4 (X axis not moving)


I bought my Ramps 1.4 and Arduino from Ebay.
I’m having a problem with my X axis operating on my Ramps 1.4 board

I have the three bridges under the driver and set the DRV8825 to .7v, I have swapped drivers around and still X axis is not moving.
I can move Y and z axis through the LCD and also on Repetier Host
I have a 100kohm ressitor on port T0

I have Marlin firmware installed, but having issues with the changes in Configuration.h
Im not using endstops

Any help would be very appreciated
Simon S

Check to see if you missed a pin when connecting the arduino and the ramps shield.

Hi Vicious1

The connections pins are all Ok.
I just bought another RAMPS board thinking that was the issue. Same problem.

Try swapping X and Y at the RAMPS board. If the problem is still on X it’s in the wiring, if not it’s in RAMPS.

Hi Bill

I tried swapping X and Y, swapped the wires and then I swapped the drivers, X axis still not working.
I actually just bought another Ramps board and same issue.
Maybe Im using the wrong Marlin firmware?
Maybe my Arduino is faulty

OK, the problem pretty much has to be outside the Arduino/RAMPS since the issue stayed put when you swapped the wires. If the X and Y wiring were swapped and the problem was on the board the problem would have moved. Try swapping both ends of the wiring this time, you can’t do it directly with the stepper motor, since its wires are built in but you can do it from the connector. This will show if the problem is in the wiring. If there’s still no change then you likely have a bad stepper or a bad wire coming off the stepper.

I’d put my money on the wiring connecting the stepper wires to the board, since if it were a bad X stepper the other side would still try to work.

Just did another test on the ramps board.

Went through Bills tips, thanks.

Currently tested with one stepper motor with 4 wires.

X axis, moves once, possibly 1mm only on Repetier, and won’t move any further.
I swap the stepper to Y axis and swap the same driver from x axis to Y axis. I move the Y axis on Repetier and the stepper moves forward and backward.
I then wire the Z axis and move the Driver and I can move the stepper motor in Repetier back and forward.

Any input would be appreciated

Check to make sure the end stop pins on the board aren’t shorted for the x axis. The movement you’re describing is exactly what my router did when one of my stop buttons got stuck.

Hi Barry

Sorry for the late reply, just got back from a trip.
I checked out the end stop pins, they seem ok.
This must be the second faulty Ramps board I own.
I have a 3D printer with a MKS GEN 2Z V1.1 that I will test MPCNC on.

Thanks for everyones help. I will let you know how I go.

Simon S

Hi Bill, vicious1, Barry

Just to let everyone know that I had a faulty Arduino board.
I am currently running a Makita laminex trimmer, and would like to
thank everyone for their help.


Simon S