Ramps board fried, Graphic controller not working


I got the “mostly printed cnc parts bundle,” along with the “full graphic smart controller” from here, and was able to get my cnc up and running with Repetier host. However, I was unable to get the controller working. It would light up, but the screen was blank. I tried adjusting the contrast pot, but that made no difference.

It was suggested that I should try switching the wires. When I did that and powered it back up, something definitely got fried on my ramps board - there was smoke and I could smell something burning. Now, I can no longer control my cnc with Repetier host, and the led on the ramps board doesn’t light up either. The controller also doesn’t light up anymore when the ramps board is plugged in, though it does still light up (with a blank screen) when the arduino is plugged into my computer.

I’m pretty sure that the ramps is toast, but any idea on how I might get the display on the controller working? I’ve included pictures of how I connected everything the first time, when the display lit up but the screen was blank. Let me know if different/more specific pictures would be helpful.



Any signs of where the smoke came from, the ramps shield looks fine, maybe the mega’s 5v regulator?

The LCD wires, what way are they in the picture, the way that smoked your board, or did you switch them back?

It smoked with the power and usb or just power, or just USB? If it was both were they plugged into the same power outlet or different ones?

Having the lcd cables in the wrong port is common but I have never seen it cause problems, the symptoms of backwards is lit up screen but no information on it, swap them and reboot and normally you get a picture. I am here to help but don’t to replace all of that if I don’t have to, I would much prefer to narrow down the problem or you can send it all back and I can fix the issue if you are frustrated.

Usually you can swap the screen wires, there should not be any magic smoke.

I suspect a defective motor driver, I had a similar issue due to some induced currents in the motor, it blew up the driver, then the screen got whiter and whiter until the regulator of the Arduino blew up.

I suggest you to buy a new Arduino (this one is likely to be unsalvable, even after replacing the regulator) plus 3 new drivers, then try again but do not hook up the motor drivers at first.
If it works, then unplug the power and plug your new drivers. I wouldn’t trust the old ones, since, at least from my experience, it is likely that the new arduino will be blown again right away if one of them is shorted.

The ramps board is likely to be fine, the screen too.

There can be many other causes, I just think that the symptoms you described correspond to the issue I had. But it may also be a defective screen, or a defective screen cable. You may want to check your cable to see if some wires are shorted. They seem to be ok on the pictures though.

I also noticed that you put a resistor on the thermal sensor pins. What is it for?

He bought the ramps from me, meaning the system has been tested. Shouldn’t be bad drivers.

The resistor is a faux thermistor reads as 25C in the software.

My mistake, it appears that the ramps is fine, and it was the Arduino that got fried. Before I tried switching the wires, I had flashed the firmware on a Mega clone that I had lying around, just in case the screen wasn’t working due to a software issue. Now that I have the clone plugged in, I’m able to control the cnc with Repetier host again.

When the Arduino went, it just had power, the USB was not plugged in. The wires in the picture are NOT connected the way they were when it started smoking. I switched them back before I took the picture. Whether it was a good idea or not, I just switched the wires again to see what would happen. No smoke/smell (though I didn’t leave it on for any longer than a few seconds), but the display didn’t light up at all, and I couldn’t hear anything when I pushed the encoder.

I’ve been working my way through this troubleshooting list: http://forums.reprap.org/read.php?219,666595 and I’ve tried everything up to and including #6. I think that I can see the hidden trim pot that #7 refers to, but I’m reluctant to start desoldering and drilling holes in the controller to get to it.

I don’t mind trying to work through the problem with the controller - a big part of why I bought the package was to learn more about cnc machines, components, and electronics in general. I have to admit though, that I’m not sure what the next step should be in trying to figure out why my display is still blank?

Send it back and I will test it, it could be a bad LCD. Sounds like you have done all the testing that you can (swap the wires adjust the contrast pot).

I will test it against a known good system. If this one is bad that would make the 3rd one in the last 300, no issues with the previous 300 I have sold. First was a bad card slot, second was a row of dead pixels.

Yes, I know.
In my example, the drivers worked fine until they got fried by the static of my vacuum cleaner the first time, and by the plasma cutter the second time.
It could be the same here, not a faulty driver from the factory, but the driver would become faulty later, because of static coming from whatever equipment he had running nearby.

Could also be something else, I don’t know. I wasn’t implying that this would be because of a defective material, I know that everything is tested before sending. :slight_smile:

Ok, will do. Thanks to all for the suggestions to help me out.