ramps/mega voltage drop

I’m seeing a voltage drop across the green connector on the ramps/mega board. Each axis is making the voltage drop ~0.5V so when my lowrider is running, the voltage at the board is 10.3-10.5V. The psu remains at 12V. There’s ~8’ of 18/4 stranded wire going from the psu to the ramps board. Currently my performance is garbage with 2mmDOC @ 6mm/s in plywood with possible skips on both the x and z axis. Should there be that big of a voltage drop?

The PSU is rated 12V 10A. Also tried an ATX power supply with the same results.

You’re seeing a drop of 1.5V between the power supply and the green connector?

Seems like something is wrong. That much cable is 0.1ohm or so. That would be 15A.

I haven’t checked my connector, but the contact resistance should be below 0.1 ohm. Have you checked the connector soldering to make sure the joints are solid (no cold solder)?

I got 0.1Ohm from an online calculator for 16’ (8 each way) of 18 gauge wire.

I would have definitely said it’s the power supply, but you said you tried a second one.

How do you know it’s each axis dropping? Did you measure that somehow?

Have you tuned your driver’s? What are they set at? Do you have the motors wired in parallel or series? Since it’s your x and z you’re having problem with, this is my next best guess.

I have the dual endstop setup (5 drivers) with the Y-axis(611 carriage) having two motors in series. My motors are rated @ 1.4A so the drivers are set to ~0.75V. When I initially power on the machine and none of the motors are engaged, the voltage at the connector is 12.09V. After engaging the Z-axis alone the voltage at the connector drops to ~11.5V and with each axis engaged the voltage drops until it gets to ~10.3V.

After retightening the set screws in the connector and eliminating some of the play in the connector I was able to get the overall voltage up to 10.8V with all motors engaged. BT may be on to something… I need to check the solder joints at the connector. I also have a spare ramps/mega that I could compare to. If anybody has their machine running today, can you bust out your handy dandy multimeter and check the voltage at the green power connector across the 5A terminals while all motors are engaged?

0.75 on a DRV8825 is probably too high for those steppers. The drivers at 0.75 would probably also need active cooling to keep from getting to hot and thermal cycling.

I just started one up and at the green plug, no voltage difference. With XY and E moving. I am getting the feeling a driver might have popped. Pull them all out and replace them one at a time until you find the issue.

With the motors off, my psu is at 12.7V with them on, 12.4V. I have three drivers X and Z are wired in serial. The cable mength I have is about 4’, its built into the PSU (It’s one of those power brick types). Probably smaller than 18ga.

Swapped out drivers with no change. Swapped out Ramps+drivers with no change.

So I adjusted the pot on my psu up to 12.75V to compensate for the voltage drop and readjusted the drivers to 0.72V. The voltage now drops to 11.9V and the performance has increased. Not sure of its full potential but I successfully cut a 25"x20"x0.75" sign with the following:

Engraving - 1/4" downcut 2 flute/ 2mm DOC @15mm/s(XY), 1.5mm/s(Z)

Cut-out - 1/8" upcut 2 flute/ 3mm DOC @11mm/s(XY),1.5mm/s(Z)

The voltage compensation seems like a band-aid for the problem but at least I can successfully cut… for now. Hopefully this helps somebody. Thanks for the support fellas!


You only have the 5A port powered correct?

My thinking is a bad mosfet on the 11A side could be heating up burning a bunch of power.

No, I have power going to both 5A and 11A. Is connecting the 11A input only needed if using D8-D10? I’m not using D8-D10 so it’s worth giving that a shot.

Nothing is really requiring exaclty 12V. The 12V is used by the D8, D9, and D10 pins and the stepper drivers. It’s also used by the mega to provide power to the voltage regulator which provides all the 5V power.

You don’t have anything connected to D8,9,10.

The stepper drivers can operate up to 45V (depending on the driver, thats from the polulu site for drv 8825).

The arduino’s voltage regulator is really the limit, and if it’s a genuine one, 20V is max:


So 12.7 or 13V is no big deal. That’s exactly why they have the regulator, so you could run it off of different power supplies. Pretty much anything that says 12V has to be pretty tolerant because car batteries are “12VDC”, which is anywhere from 9V to 15V. Similar stories with 3S LiPos.

All that to say, don’t worry about adjusting the power supply. It’s fine. It is still weird that it’s dropping that much, but you shouldn’t be so close to the min anyway.

Back to the weird drop though. Can you measure the amperage going through those cables? Or can you measure the resistance anywhere (along your cable perhaps?). You’re either sucking a ton of current (the mosfet short as Ryan suggested) or you’ve got too much resistance (bad solder or the cables have a break somewhere or some other gremlin).