Reset all coordinates not working

Hi All,

So I thought I was going completely crazy. I just finished my MPCNC build. Ran a few crown tests that seemed to go well. I then created a very simple “part” that was a cylinder with a tube cutout on the edge.

The problem I keep running into is the coordinates do not seem to be resetting when using the “reset all coordinates” in the V1 menu.

I am running a miniRambo1.3a board and FreeCad fo CAD/CAM software. I am printing off an SD card.

I do notice a G92 X0 Y0 Z0 in the grown test and I do not have that within the part gcode I have created.

Just wanted to see if there was something I was doing wrong. As I know the ultimate issue there are a couple work around I plan on using tomorrow for the first cut.


Reset all coordinates should be exactly the same as G92 X0 Y0 Z0.

Here is a primer we wrote a while ago. Hopefully it is all still true:

Reset All Coordinates establishes the current position of the router as the home/origin position, which will become the origin (0,0,0) of your cut. And I just looked at the current V1 maintained source code, and Jeff is correct that all that command is doing is a G92 X0 Y0 Z0. But that does not necessarily mean it will behave how you expect. For example if you are using EstlCAM, you might want to take a look at this setting under Basic Settings:


You have to define where 0,0,0 is relative to your stock. This definition is done in different ways in different CNC authoring tools.

In my opinion, when you are starting out, the easiest solution is always define your start position as the top of the stock and execute a G92 X0 Y0 Z0 at the start of each of your jobs. It is possible to have the G92 inserted automatically by your authoring program, and often it can also be automated in the g-code sender.