Saving steps per MM

In CNCJS I used a M92 command to change the steps per MM of my mpcnc and that all works. But, when I disconnect the board or close CNCJS and then reconnect the steps per MM are all back at the default. Is there a way to save my changes in CNCJS? Or do I need to change the defaults in the firmware?

You can save the active settings (all of them) to EEPROM with M500.

1 Like

Will these gcode commands also work with Repetier Host and a Rambo v1.4 board? I’m currently at the point in calibration where I need to tweak the steps per mm. And when you say “all of them” do you mean the steps per mm for each axis? Thanks!

Those are the same commands. By all of them, I mean all the settings you might have changed.

How far off are your steps/mm?

Honestly I’m still trying to wrap my head around calculating the steps per mm, I’m trying to cut a 5in x 5in square and keep getting 5.030in on the short axis and 4.930 on the long axis and it seems to be regardless of how much I loosen or tighten the belts.

The motors have exactly 200 steps / revolution. The gears have exactly 16 teeth. The belts should be very close to 2mm/tooth and the drivers have exactly 16 microsteps/step.

200 steps/rev * 16 microsteps/step * 1 rev / 16 teeth * 1 tooth / 2mm = 100 microsteps/mm

So if things are a little bit off, it isn’t because of the steps/mm. The belts can stretch a little bit, which is proportional to the distance traveled. But other than that one issue, there shouldn’t be any reason to adjust the steps/mm. I also wouldn’t do that with a cut, I would do that with a pen or just measuring in the air. Make sure you dont have the steel belts with white rubber. The steel breaks easily and then they stretch.

On the cuts, there are more things that can cause issues. One might be CAM (going to fast, or not using a finishing pass). You should check the grub screws on the pulleys. On a low rider, you should check that the wheels aren’t slipping sideways. And then just generally look for loose bits.

1 Like

Darn, I was really hoping I could solve this by just pushing some numbers on a keyboard instead of actually having to dive into the machine haha.

I may be a bit aggressive, I’m cutting 1/2in birch at 10mm/s and a 6mm doc. I 3d printed some guides that allow the long axis to roll along the table so the wheels shouldn’t be slipping but I’ll double check that as well as the grub screws.

Thanks for the advice, I’ll be trying all this out this evening at the shop.

You should be able to push it pretty hard. But the more you push, the more flex there will be in everything. You can add a finishing pass in Estlcam which backs off a bit on the first cuts, then does a full depth pass right on dimension that just removes the dust left the first time. It can actually help make parts smaller or bigger, because the first pass is backed off a bit. Something less than 0.5mm, often down to 0.1mm is enough to get dead on dimensions, while keeping the hogging operation fast.


I’ll give this a shot for sure. I’v got Estlcam but have been exclusively using Fusion but I’m starting to think I may give Estlcam another go since there are way less options and less opportunity for error. I doubt it would make a difference, but I’ve switched my X and Y axes to where X is long and Y is short. Is it possible that this is having some sort of effect?

It shouldn’t matter. As long as you put your workpiece the right way.