Scale: inches to mm

Received gcodes files for an inlay. Loaded to SD Card and inserted into controller. Machine will run the code but in very miniscule movements, this is a 10 inch inlay. Guy I bought the MPCNC from said it’s because the gcode file is in inches rather than metric. Understand cannot just change the G20 to G21 as that would not change the design parameters. This is my first attempt at using CNC and am at a standstill. Any guidance would be appreciated. SKR PRO -V1.2, 513D, TFT35-E3 V3.0

Posting the Gcode would help. If the the GCode is in inches then it should run with G20 active.
Usually GCode files start by setting the necessary modal states so the units in which the file is generated should not matter. You should get your work as supposed to (independent of the used units).

Maybe the GCode also has some settings that changes the steps per unit that do not match your current configuration.

By default, the Marlin versions maintained by V1 do not have inch mode enabled. If you want to enable inch mode, uncomment this define in configuration.h, recompile, and reflash your board:

// G20/G21 Inch mode support

I’ve mentioned this as a possible fix a number of times on this forum. The other fix is that in every CAD/CAM/Postprocessor setup I’ve seen there is a way to force the output of g-code in millimeters even if the original file was authored in inches. So far no one has reported back about enabling inch support in Marlin, so I view this fix as “probable” but “untested.”

FYI: Running g-code files produced by someone else has its dangers and should be approached with caution.