Screen lights up - no text

I’ve just finished building my MPCNC.
Rambo 1.4
Bigtree Tech Smart Controller
All wiring, motors, Rambo, and screen purchased from V1 Engineering.

The screen lights up when plugged in as shown, but I can’t get any text to show up. I’ve tried all the different plug arrangements.

I’ve reviewed this thread:
Rambo 1.4 and LCD issues - Mostly Printed CNC - MPCNC / Troubleshooting - V1 Engineering Forum

Is it possible my Rambo did not get flashed prior to shipping? I bought it earlier this year (2021), maybe 3 months ago?


The potentiometer right above your thumb in that picture adjusts the screen contrast, try giving it a twiddle.

1 Like

Have you checked the orientation of the connectors? They must be flipped the right way. I’ve marked mine, I always tended to get them wrong…

1 Like

The potentiometer doesn’t seem to make a difference…I mean, I can see a difference in he screen, but still no text.

I’ve tried flipping connectors around, flipping cables around, and even switching the cables. Nothing seems to matter,

I was hesitant to reflash until I knew for sure it wasn’t flashed initially, in case I do it wrong. Is there any way to know if it has and software on it?

In the only picture where I can see power, the power is disconnected. You need 12V for the rambo to do anything.

You can connect with repetier host or cncjs to send and receive gcode from a computer. If you can do that, then sending M115 will respond with a version string and it will say Ryan, V1Engineering and v510 or v513. Connect at 250k, not 115200.

Your gray cables are wrong. On the screen they are facing different ways (flip one to get the connects the same), and on the board they are facing the same way. The instructions show a shot of the board and the gray cables carefully laid out so you can follow the orientation of them.

1 Like