SD init fail

Hello, I’ve seen a couple of posts regarding the LCD card reader not reading the sd card on a Rambo 1.4 board. Has anybody found a solution?

It was able to read the gcode twice off the card, but no longer can read anything. It’s a 8gb sandisk ultra 40mb/s sd/hc 10 card. Have also tried a Samsung 32gb microsd with an adapter and that did not work. However, I can still read and write to it from other devices.

I’ve also tried re-seating the cables of the LCD with no luck.

I got everything, including the Rambo 1.4 board from here. Any advice will be appreciated. Thanks

How’s it formatted?

1 Like

What firmware version (we had issues with a couple releases that was patched quickly)?

If your card was read ever it should be fine. Make sure you are formatted fat32, and have the newest firmware “510s/d”. You can also try putting your .gcode files into a folder on the card, that seems to help.

What actually works best is slower smaller cards, so trying faster, newer, “better” cards doesn’t help.

Thanks for the responses. It’s formatted fat32

Hi thanks for the response. I don’t remember the firmware version but I’ll make sure to post it when I get home (and I’ll make sure to put that in original post next time). I tried putting the gcode into other folders, but had no luck.

I did have luck reading the card twice, so I’m keeping hope alive and sounds like I need to try a slower card as well

Thank you both for the responses!

Looks like I have version 509

I’m fairly new to this, I think 509 is the version? If I did not get this correct, what’s the best way to find the firmware version. When I look at GitHub, all I see is marlin 2.xx. Where would I get the “510s/d”? Thank you

MarlinBuilder releases has the latest for download.

There is a firmware.hex inside the zip. Use Xloader to flash the rambo with that.

1 Like

Thank you jeffeb3, I see where I’m supposed to get the correct file and how to flash my Rambo board. I will try it later today when I am home.

I’m thankful at how helpful everybody has been


One more update. Attached is a screenshot of what I’ve tried and upload keeps failing. Under device, the options I have are cc01 and cr03. I’ve tried 115000 as you did in the link you sent.

Thank you!

Hmmm. What about the instructions here: Xloader.

@robertbu, any ideas?

XLoader is not connecting on COM3. No magic bullet but:

  • Check other COM ports. You may have more than one COM device connected, and COM3 may not be the one the Rambo is using.
  • Make sure the Rambo board logic is powered. I see in your picture at the top you have the board wired, but it must be turned on when you attempt to flash it.
  • Try a different USB cable.

I tried different USB ports and different cables, all with the same result.

Every time I try to flash on Com3, I notice that about fifteen seconds into it, the LCD restarts and then xload says upload failed.

I tried the instructions suggested as well by jeffebb3, following that exact sequence. I went as far as to remove all com ports, and just install the Rambo board as the sole com port with no luck.

The screenshots that mentioned Mega(ATMEGA2560) were really helpful because I assumed this would automatically be picked up by Xloader. But I re-downloaded XLoader and saw that in their devices.txt, it showed the only two choices I kept seeing, the cc01 and cr03.

So, I figured why not give it a shot and added the following in that same text file


Restarted XLoader, then I saw the Rambo entry I had just entered, and was able to flash it finally.

I think this is the fix. However, I did use arduino board

manager plugin prior to this. So that might have helped as well. Not too sure.

Regardless, thank you all again


I’m glad you tracked it down. The devices.txt I downloaded has these entries:


We will keep this in mind. That is strange.

So does the sd card work now? I had to ask because just yesterday I was 3hrs into a print and it suddenly stopped. Turns out the card slot in my lcd was a bit intermittent… same exact rrdg lcd you have too.

I am in need of upgrading my printer to 32bit for more memory, and a micro sd slot is something I am looking forward to. I think the full size slots in lcd screens with the micro adapter is just asking for trouble on something that vibrates all day long.

Hmm, I wonder why mine didn’t have those. I just have followed a different link or something

after the firmware upgrade, I tried a couple of different cards and it worked like a charm.

I made an engraving test that was about five minutes and the card did fine. Prior to the update, the two times it worked, it gave up in the middle of it