Shaking when above 200mm/m feedrate

Good evening gents… SO I know few of you have lasers, but im working with piclaser, and my feedrate for that should be in the 2000-5000mm/m range, even as high as 70-100k per minute… The laser is powerful enough to draw a picture at that rate.
However, anytime i go above around 200mm/m which is true engraving speed it shakes and lurches a LOT.

Now i dont think its the CNC at all, i think its software… Heres why… when i do a 50 move command (the max repetier can do) it works flawlessly. and SMOOTH as heck.
When i do a test print around all the edges just going and going, SMOOTH as heck.

What in piclaser or any other software would cause this?


I think it is the acceleration setting in the firmware. The max stock feedrate is 197mm/s so you are basically 60x’s below that. For milling the acceleration is low so it doesn’t jerk the heavy tool around on sudden moves. The laser gcode probably has a ton of speed changes, constantly hitting the jerk and accel limits.
A quick experiment would be set the speed to double what you have it now and run the machine at 50% feedrate.

speed and feedrate are the same to me? im kind of a dullard when it comes to these things haha.
am i setting changes in firmware? or just in my laser software?

Sorry It is the same thing usually. In your software change the speed to double, then on your lcd or repetier turn the feedrate setting to 50%. I think that should clear it up.

I haven’t messed with the laser too much but if you can change the travel and the burn speed to the same. For example if your software trys too move faster when it isn’t burning it will trigger the acceleration limits, but if it never changes speed it should move smoother.

I could also be very wrong on all of this.

I am done for the night but if you want to zip the gcode and upload it here it might help to understand what is going on. I can look at it tomorrow.

well in printer settings in repetier i see the feedrate is set to 4800mm/m so i tried that speed knowing that when i click manual moves at that rate its smooth.
WEll its not in the laser software, so something is telling it to jerk.
just more info for you

ok. ill make the changes and post results.

Yeah, so no change… in fact i just tested laseretch (jtech software) and im running engravings at 2000mm/m there with no issues, which is fine if i could get the working in piclaser as well. Im just realizing that the speed is hitting those limits you mentioned and no change in the software will change that. its something inherent to it.
but others have used piclaser, so i guess ill have to figure it out. or chuck it.

anyone? karl? :slight_smile: jay from jtech (i emailed you earlier).

It happens in image2gcode too, so its something to do with the way its handling images vs just laseretch software, or normal stuff.

8 bit Laser engraving requires a much faster flow of gcode commands than vector engraving. I’m not familiar with repeater. Have you tried running the gcode directly from sdcard? How fast are your serial coms?

leo, i havent tried running it from an sdcard… i havent actually hooked up my LCD :slight_smile: which is SD as well haha… i think i tried hooking it up once but it didnt work… maybe i didnt hook it up right

If your laser resolution is set to .1 mm then you’ll possibly be processing 10 g1 move commands AND 10 laser power commands for every mm of travel which adds up to 20000 commands per minute at 1000mm/min feedrate. Communication must be fast and uninterrupted for this to work. I would suggest getting the sdcard working to troubleshoot further. I use marlin and found that my laser stuttered a bit after upgrading to 12864 LCD even when running from sd. I noticed my stuttering was occurring once per second, same rate as display refreshes. I studied firmware and found that the u8g library is quite the resource hog so I disabled screen refresh during laser operations to correct the problem. Unfortunately we’re really pushing the limits of what the firmware is capable of. You may consider grbl for laser engraving since its much purer and unburdened by display updates , temperature monitoring, etc…I’m in the process of switching back to mach3 myself. I enjoy coding but I’m spending more time rewriting firmware instead of getting my mpcnc dirty lately so its time to leave Marlin behind.

Leo thanks for the info…
Right now im actually having an issue getting my LCD working… I try to enable the LCD in my arduino configuration.h but getting errors. failing to figure out how to get or what to do with the u8g stuff… ill keep working on it, but if you have an easier suggestion that would be great.

nevermind, i got the lcd working. trying SD now

doesnt really seem to matter if i run off of the SD card or not… same result… running GRBL instead of jtech in the software just doesnt work at all. im guessing the commands are different so id have to figure those out :slight_smile:
it really sucks not being able to use a huge feature for why you bought your laser in the first place :slight_smile:

EDIT : how would i go about disabling screen refreshes? i dont even want the LCD :slight_smile: but ill use it if i have to to make this work haha

Ok so this is interesting. I think Ryan may be on to something as far as the acceleration and jerk settings go. Can you create gcode for a small image using both laseretch and image2gcode and post them here? Also post your config.h file. Now that you have lcd hooked up it’ll be much easier to play with accel and jerk settings. They can be changed through lcd interface and the new settings will be written to eeprom. Even under ideal conditions i wouldn’t expect 8bit laser engraving to perform very well at speeds over 1200mm/min or so. The hardware is capable but i doubt the firmware is.

Leo… when i get back home in a little bit ill do that leo… However, i run 2000mm/m for laseretch and dont have any issues with jerking… Perhaps image2gcode, or piclaser is issuing many more commands than laseretch is. Or perhaps laseretch is much more efficiently using commands :slight_smile:

Probably a bit of both.As I understand it Laseretch only does black and white, not grayscale. That means there’s no need for constant laser power commands and it also means multiple “pixels” can be consolidated into one linear motion so I’m sure your right. If you want to do8bit grayscale then you have to accept that it’ll have to be done a bit slower. Your current 200mm ceiling should have lots of room for improvement though.

leo,… so i think i may know (and this is obvious now) my problem, or at least one of them.
my image size/quality… ive been saving them as BMPs, but not 8 bit greyscale BMPs… I never figured that part out.
However, saving it as 256 color doesnt convert it to greyscale… is there any native way in PAINT to do that? or do I need another 3d party product to handle that converion to greyscale.
i think thats a large part of my problem here.

EDIT =- so i found GIMP software, which I can convert it to grayscale, but exporting it as a BMP doesnt give me any quality options and it looks fairly high quality even at grayscale.
So now perhaps I need to change it to 256 color in paint, what a pain in the ass… there needs to be one program (not photoshop, i dont wanna pay for that haha) to convery from a jpgh to 8 bit grayscale :).

BTW, i tested it with the normal grayscale higher quality and it was WAY faster, less stuttering, still a bit though.

EDIT EDIT - so loading it in to paint, and then saving it, shows its already at a 256 grayscale. so that wont make a difference. . poo

OK. so a few more changes.

Set speed to 1000
pixel rez to .25 instead of .17

and this seems to be working great.

However if i even go to 1200 speed there is a little stuttering, even more at 1500, etc.

Now to try SD card with 12–/1500

No need to convert. The software will convert a color image to 8 bit grayscale which matches the pwm capabilities of your firmware. Post gcode when you get a chance