Should have listened to Ryan and got a Rambo for my first board. Problems with SKR1.4 and TFT24

I got (eventually) an SKR 1.4 and a TFT24 V1.1, and am having no end of problems trying to get the touch mode working. It just refuses to communicate! I’ve reached out to a few sources and am giving up until they get back to me.

It seems to be talking to Repetier so for now I’m just going to keep forging ahead with that, and I’ll keep you updated if I get it working.

No question really, just a vent and a reminder to myself to post a solution for others if I ever get it.

I needed help getting mine going. Don’t know if you’re having the same issues but maybe this thread will help.

https://forum.v1engineering.com/t/build-complete-need-tft24-help/15691

Thanks for the response. I found your thread earlier, but unfortunately doing those things hasn’t helped.
I tried:

  • Reformatting SD card before uploading firmware, both for the SKR and and TFT
  • Serial_port 0 and serial_port_2 -1, and vice versa
  • m502 and m500

I’d be interested to have a look at your firmware, if you have it somewhere?

MPCNC or lowrider2?
Dual endstops or not?
Which drivers?

Lowrider 2, Dual endstops, A4988s.

Screen still isn’t talking in touch mode, and I’ve not heard back from BTT. Also, I seem to be having trouble on my Z axis, I think I’m not sending enough juice to the steppers, and the vref on the A4988s maxes out at .72 where I believe it should be set to .96.

But! I did manage a ‘successful’ crown test!

Yep, I went through those already. Thanks though!

Hi Pok, when you say

For clarification, does the tft show the icons you would expect to see but does not respond to your touch and does the “printer not connected” message extinguish after a few seconds and the screen still doesn’t respond to your touch.
(I am assuming the TFT24 is pretty much the same as the TFT35 and the SKR v1.4 the same as the v1.3)

AFAIK if you set SERIAL_PORT_2 -1 in your SKR v1.4 configuration.h and specify BIGTREE_TFT24_V1_1 in the TFT24 platformio.ini file and the comms speed in TFT24 configuration.h is set to the same as in the skr configuration.h … it should work.

@dart1280 Apologies, I’ve been lurking the forum and somehow missed your reply. I’ve been troubleshooting with BTT (difficult!) and if I understand correctly they are sending me a new TFT, possibly a board as well.
For completeness, the TFT does show the icons and does respond to touch. I’ve since wired it up to an arduino and it looks to be an issue with coms on the TFT itself. I can send serial to it, which appear in its terminal, but I cannot receive anything from it.
Thanks for your efforts.
In the meantime, I had a spare Mega so I grabbed a RAMPS board (not many other options in Australia and I didn’t want to wait any longer) and got some cuts.
I’m drafting up a ‘my build’ post now.