Shuddering on X and Y, only on stepper power.

  1. Did you buy everything from here? - Printed parts here and bought kit
    a)If you didn’t or changed some things please don’t leave out any details.
    b)What firmware? - Marlin, direct from website 3 days ago

  2. Are you using end stops? No
    a)If so please disconnect them.

  3. Are you using all my recommended parts? Yes.
    a) If not please list what parts you used.

  4. Include a picture so obvious errors might be spotted.

So the problem I’m having is shuddering on the X and Y axis. The gantry moves smoothly when I’m shifting it by hand but when I attach my belts and string them over the steppers I get binding and shaky movement. So far I’ve tried running an hour of full print area rectangles, my pipes are nice and smooth but no change. I’ve checked all the motors without the belts attached and they are all moving and turning the correct directions. I’ve checked my set screws on the toothed gear on the motors and those are all tight. I suspected my belts were over tensioned so I did a non-scientific test of cutting them and using just enough tension to stop the belt from skipping.

My speed setting in ESTLCAM is 25mm/s. I’ve tried as high as 150 and as low as 5 and neither seems to make noticeable difference.

Any other suggestions on things to check/test?


Looks like you did all the right troubles shooting. Take off the belts and see if each has roughly the same power if you try and stop them from moving by hand. 1 stepper might have a loose pair making it move but only have half the power.

More likely the driver for that axis is not set correctly. Since it is all my stuff make sure the X and Y axis are close to .7V and the Z is .47Vish.


I checked the steppers and the voltage, all that seemed right.

It turned out that my belt tension was not even. Once I got both belts to the same tension the shuddering went away. I think the looser belt was allowing it to torque the center just enough to cause shuddering and binding. Restringing the belts and getting all 4 to the same tension appears to have resolved the issue.