Simplify3d 4.0

The Physical solution will Require a lot of Rewiring the more I look at it I would love to have some help

I attached my Firmware file



GOD Bless

Marvin (782 KB)

Marvin, did you want to try the gcode fix first?

This firmware has been modified by you for auto leveling, right?

It looks like you’ve set the bed positions like this:

// Set the boundaries for probing (where the probe can reach). #define LEFT_PROBE_BED_POSITION 200 #define RIGHT_PROBE_BED_POSITION -200 #define FRONT_PROBE_BED_POSITION -100 #define BACK_PROBE_BED_POSITION 100

The right and front positions should probably be 0,0. That should make the G29 at least go to:
10,90 etc.

I bet you dollars to donuts that’s the issue, but I’ll peruse the rest of your config and see if anything else sticks out.

I was wrong, I think it is this (but that other stuff should be changed also):

// Use “Z Safe Homing” to avoid homing with a Z probe outside the bed area.
// With this feature enabled:
// - Allow Z homing only after X and Y homing AND stepper drivers still enabled.
// - If stepper drivers time out, it will need X and Y homing again before Z homing.
// - Move the Z probe (or nozzle) to a defined XY point before Z Homing when homing all axes (G28).
// - Prevent Z homing when the Z probe is outside bed area.

#define Z_SAFE_HOMING_X_POINT ((X_MIN_POS + X_MAX_POS) / 300) // X point for Z homing when homing all axis (G28).
#define Z_SAFE_HOMING_Y_POINT ((Y_MIN_POS + Y_MAX_POS) / 150) // Y point for Z homing when homing all axis (G28).

I guess I’m not sure what your geometry is, but when x and y home, the corner of your heated plate will be at 0,0, and it’s 200mmx400mm? You can just manually set these to something that makes sense: