Skipping steps because of weak motor?

I‘ve now twice had jobs fail because the machine skipped steps. This was partially also because of my CAM I think (it was removing material more aggressive than wanted, because a previous process left more than I thought). But also my X and Y motors are older stepper motors from an old 3d printer with a holding torque of 66.66 oz-in. I know the ones sold in the v1 shop are 76ox-in. And I also found some that even have 92oz-in. Would these stronger motors be beneficial or not really worth it? My feeling is that right now the motors are the „weakest link“ in terms of how aggressive I can mill.

More details:

I have the motors wired with one driver per motor. I don‘t think the skipping issue is from overheating drivers, because on the second job I had it running for a while after until I noticed the skipped steps and all parts afterwords worked perfectly fine. Just… shifted.

You set the current limit on the driver’s, right? It probably depends on the driver, but mine have stopped for minutes when they overheated (drv8825s).

I suspect your motors too (assuming your drivers are set).

1 Like

Yup, for this tune the drivers and your feedrates and rapids (if you are using my firmware), If you are using your own firmware you will also need to deal with accelerations.

1 Like

Those steppers should be plenty strong.

1 Like

I have set the current using a multimeter. Is there an additional way I should/could be tuning them? As mentioned, I don’t suspect the drivers overheating, since the job did continue for about 5 minutes or so and seemed to be working correctly. (just shifted, because of the earlier step loss)

Do you know of any guides/tips for how to figure out the correct values? I’m using a custom firmware, but did go through your firmware and copying the relevalt values. (I think I got all).

Today I tried to do an engraving using a 60 degree vcarve bit. It mostly went well, but it did lose some steps on the deeper cuts. I tried using a 500 mm/min feedrate. My assumption would be, that something like this should work with stronger stepper motors without loosing steps? The rest of the machine seemed to handle the cutting speed pretty well in terms of accuracy/rigidity. With my current setup, would there be other settings I could tune, other than a slower feedrate, to make something like this work?

One thing I also noticed when looking what other motors are available, is that the ampere rating on mine is very high compared to other motors. It has 2.4A listed. for example the 92z-in ones I found only have 2.1A. I’m not sure if that would even be relevant.

What about your Rapid rate? Does my crown gcode ever skip a step?

1 Like

If your using a ramps board with a4988 the Rs value is more than likely .1 ohms. Every tutorial I’ve found online uses .05 for the math, and you end up setting it to half current.

 

1 Like

What is the coil resistance of your motors? Are they 4-wire or 6-wire?

1 Like

Stupid question, but which value is that? I haven’t actually run your crown gcode, but have done multiple drawing tests with my own gcode that neve skip a steps. I can also do cuts in wood fairly well as long as my cuts are pretty shallow. Less than 1mm seems to be safe most of the time, but everything above that skips steps at some point. I know that an MPCNC is not meant to do super deep cuts, but given that my attempts with p.e. 2mm depths went well except for eventually skipping a step I feel like the larger motors could help.

 

I’m using DRV8825 drivers.

 

The coil resistance seems to be 1.25 Ohms according to https://solarbotics.com/product/33600/

The motors have 4 wires. I bought them 6 years ago or so for a Prusa i2 3D printer.

What did you use for VREF when setting the current limit? Have you verified the value of your sense resistor?

Use my crown gcode for testing so we know that is not the issue.