SKR 1.2 + TFT - Marlin works but Touchscreen = 'no printer attached

Installed firmware on both board and TFT. I can long press the knob and switch between the two modes. Marlin works - I have control over all axis and can verify movement is normal. Touchscreen mode reads ‘no printer attached’.

I’ve read through the posts here and tried to change baud to 250000 w/ no luck. Also tried a variety of connections with the gray cables omitted and the black TFT cable omitted. The numbers on this pic in the instructions are super confusing. But, I imagine that if marlin works via the knob, the gray cables are setup properly, rt?

I think when I first set it up I had the black TFT cable plugged in upside down on the board. Could I have fried the touch connection?

I don’t mind using the marlin interface - would I be losing any functionality by doing this and avoiding the touch interface?

Thanks -

j

Your serial cable looks to be placed right. Reversing the cable does not do any damage (guess how I know that). So it must be a firmware or speed thing. Which firmware (mainboard) do you use?

Try setting
#define SERIAL_PORT -1
and
#define SERIAL_PORT_2 0 or
#define SERIAL_PORT_2 1

Thanks for the quick reply - I downloaded and flashed the non-end stop variety firmware named: V1CNC_SkrPro_2209-2.0.7.2-src

Would I be making those serial adjustments in the TFT’s config.ini file?

no, in configuration.h of the SKR-firmware

Ok - I found the configuration.h file within the marlin zip file - I can open this via text editor and make the changes. Would I then need to compile a new firmware.bin file and flash it to the board?

yes, but editing can also be done in VS-code…

Ahh - ok - I don’t have a working copy of MS Visual Studio. I’ll try compiling and flashing a new build after I down some food - thanks!

Well, gave a good meal :wink: It is almost 3AM over here, so I am off to bed

That firmware is set up already for the usb and the tft connection. On the pro, it is -1,1.

The black cable is the one that connects it in the touch screen mode.

So, my configuration.h file was set to:

#define SERIAL_PORT 1
#define SERIAL_PORT_2 0

You’re suggesting it should be

#define SERIAL_PORT -1
#define SERIAL_PORT_2 1

That was easy but I just went down a rabbit hole trying to build the firmware. According to these instructions, Since SKR is an arm cortex board I can’t use Arduino to compile the firmware. I walked through the downloading marlin instructions on installing via sublime text 3 and also installed Python 2.7. I believe I successfully built the autobuild menu.

When I run Auto Build > PIO Upload I just get a blank black window. Upon closing it I can see the code that ran. It includes:

FileNotFoundError: [WinError 2] The system cannot find the file specified

And it also lists python version 3.7.2 (I have an alternate build of python installed for other projects)

Am I on the right track here or is there an easier way to change 2 characters and create a bin file?

I should specify, not sure if it makes a difference - I don’t plan to use the USB port and tether to a computer - I’d just like to use the touchscreen menu if it has extra features beyond marlin. Eventually I’d like to add a gamepad/joystick for moving the machine, but from what I read I’ll need a Pi and more code.

What OS are you on?

The most easy way is to install VS-Code. I love the video’s from Chris Riley on this subject: https://youtu.be/oHMZ0ocTYvM?t=888

To test, here is a fresh build binary: firmware.zip (110.9 KB)

Cheers,
Kees

Those settings are not in the firmware Jonathan mentioned, therefore should be altered.

It is probably my memory that is wrong. The firmware in github is right.

No, I just checked. The firmware should be set to 1,-1.

Now I’m wondering if you have the wrong firmware.

It should be one of the skrpro ones from here:

MarlinBuilder releases.

Well, perhaps Jonathan can try the firmware I built. Afaik serial port 1 is reserved for something else and can not be used for the TFT screen…

check SKR PRO Serial Ports · Issue #18 · bigtreetech/BIGTREETECH-SKR-PRO-V1.1 (github.com)

From that post:

Serial port:
-1 is for USB CDC
1 is for TFT
6 is for ESP-01S

I meant the first serial port is reserved for usb connection with host end therfore should be -1.

I don’t think so. This firmware is what Ryan ships and he and I have both tested it.

If Jonathan has firmware where they are set to 0,1, then I am guessing it isn’t from marlin builder. Or maybe it is the skr1p3 version.

Very cool - I didn’t realize VS Code was a separate (and free) program apart from MS Visual Studio - I was able to download the and install it - followed Chris’s video - thanks for that Kees. I compiled and uploaded the new bin w/out issue. I can tell the new firmware took - I see a custom name for the CNC that I specified via the Marlin mode.

First I tried the -1, 1 settings for SERIAL_PORT I’m still got a 'no printer attached error). I also tried the firmware Kees compiled and that had the same result - still no printer via touch. Then I tried the 1, -1 that Jeff just suggested and still the same result.

I am using firmware found here: Marlin_V1CNC_SkrPro_2209_2.0.7.2_508-src

I just downloaded the ZIP again and opened it in a new folder - checked the configuration.h file and it does read 1, -1. I copied the firmware.bin file to the micro SD and installed it - reset the board and I still get the same ‘no printer attached’ message via touch mode.

Here’s a screenshot of my downloads folder - I believe I’m using the right files and have been since last night:

Not sure why I’d have different values for serial.

Maybe I should wipe both board and TFT and start fresh?

Did you use the right port-speed settings?