SKR 1.3 with no response from the stepper drivers

Hi everyone.

My problem is similar to others found here, however I couldn’t find a solution that worked for me, so I’m asking for community help.

I’m using the firmware.cur that user DAK, pre-compiled, and made available here

At this time, I can get almost all motors to work with pronterface, but when I run the M122, I get this:

> Driver registers:
> X 0x00:00:00:00 Bad response!
> Y 0x00:00:00:00 Bad response!
> Y2 0x00:00:00:00 Bad response!
> Z 0x00:00:00:00 Bad response!
> Z2 0x00:00:00:00 Bad response!
> Testing X connection… Error: All LOW
> Testing Y connection… Error: All LOW
> Testing Y2 connection… Error: All LOW
> Testing Z connection… Error: All LOW
> Testing Z2 connection… Error: All LOW

I do have the jumpers under the TMC5160 stepper drivers inserted into SPI mode.

Also tried to compile TT firmware, but couldn’t solve all the errors I get in VS Code.

As I’ve said before, my X motor only works from time to time, so I’ve made some tests:

  • Connect Y cable to X motor (Worked)
  • Connect X cable to Y motor (Worked)

So I can assume it has to be firmware, as the motor, the cables, and the steppers are working fine.

I’m not smart enough to try to compile a fresh firmware, with all the changes it as to be done, so does anyone have a clue of what’s happening here?

What drivers do you have? Is it possible they are configured in “standalone mode”?

I use the TMC5160, and I’m using the pre-compiled firmware provided by DAK, so I can’t check the settings, however, I believe this pre-compiled firmware is based on TT firmware version.

Checking the TT version of the firmware, the drivers are not configured as standalone, so I don’t think DAK changed that.

I’m going to send him a PM, and ask him for the firmware files.

I don’t have any 5160s, but some of the tmcs can be soldered in a way that makes them act like drv8825 dumb drivers. It should have indicated that in the place you bought them from. That’s what I mean when I say standalone. In standalone, they won’t talk over spi.

There was also some talk a while ago about bending one pin or shorting it on the 5160s. I can’t remember.

I had removed one of the pin’s and soldered a wire between CLK and GND, as supposed on TMC5160 v1.2!

I’ll post some pictures once I get home…

I run a SKR1.3 board with 5160s, dual end stops. Let me know if you would like to try my firmware.cur file.

1 Like

It would be great if you could share your files…