SKR 1.4 Capacitive Sensor Board reading always open

Hi, I have the new 1.4 Turbo board. I also have LJC18A3-B-Z/BX NPN NO DC 6-36V 300mA 1-10mm Capacitive sensor. Worked fine on previous 1.3 board. I know there might be an issue with the board resistor but can’t figure this out. It always shows as z: open. And yes, the sensor lights up when sensing.
I have tmc2209 with the diag pin cut off and jumper set to use uart.

Current code in configuration.h is: (I tried every combination I can think of and same issue, so lets start from here please).
#define Z_MIN_PROBE_PIN P2_00

Current pins_BTT_SKR_V1_4.h
#define Z_DIAG_PIN P1_27 // Z-STOP

#if Z_HOME_DIR < 0
#define Z_MAX_PIN P1_00 // PWRDET
#define Z_MIN_PIN P1_00 // PWRDET
#ifndef Z_STOP_PIN
#define Z_STOP_PIN P2_00 // Z-STOP
#define Z_MIN_PROBE_PIN P2_00

Do you need to change the pullup/pulldown on that endstop pin?

I might. I just don’t know what to look for or test. I can’t even confirm what the pin settings should be in pins…h as well as the settings required in config.h
There is tons of conflicting information out there and nothing seems to work.

latest settings: configuration.h
//#define Z_MIN_PROBE_PIN P2_00 // Pin 32 is the RAMPS default

current settings pins_BTT_SKR_V1_4.h is set to default settings

Sensor is getting 12v from board at fan location. Sensor pin is plugged into pin 27 at z (same as used in v1.3

Is that on? The fan ports aren’t always on.

I didn’t look at the sensor you posted, but 12V back would be not-good for the skr.

Yes, it’s always on. The sensor lights up just fine when sensing. I used the exact same configuration for v1.3 and it worked fine. The output is not 12v to the sensor wire. The sensor wire barely gets any voltage. It’s just a signal. I know there is an issue with 1.4 and the resistor setup for the pins but I can’t confirm which resistor to check for. The row of resistors that have relevant numbers are all 103, indicating 10000 which should be fine.

I tried a mechanical limit switch and it reads as triggered when supposed to in the z position. However, it doesn’t stop the z movement down when triggered at the bottom. I’m at a loss because I either get no reading on capacitive sensor or I get triggered on limit switch but it still moves past.

It is always triggered when you use a microswitch? It probably needs a pullup resistor.

But that doesn’t make sense for the sensor.

Voltage or current? It needs to have enough voltage to trigger, but it is a high impedance input, so it shouldn’t allow any current. But still, if you give it 12V, it can very easily break something. But maybe the circuit is helping you, IDK.

Didn’t check current. The point is, it worked fine with this exact same sensor on 1.3
There is very little voltage passing through the signal wire. I tested on multimeter and it showed .7 mv (or something like that).
I don’t know why I can’t get marlin configured now for using the limit switch instead. I just want to test the new build and can get the other sensor working later. Like I said, it now shows triggered on z_min as it should but it keeps going down past. I remember in an older version of marlin that there was a way to bypass the z_min for setup purposes. Is that still there somewhere in marlin 2.0? I might have it allowing lower travel still.

0.7mV is never going to be enough to trigger the endstop. It doesn’t read current. It is looking for a digital signal that is eitger 5V (on) or 0V(off). Somewhere in between is where it decides if it should be on or off. It is an oversimplification, but it may be that anything above 2.5V is going to be considered on and less than 2.5V is going to be off.

One possibility is that the sensor doesn’t toggle between on and off. It toggles between (floating) and (ground). In that case, if you wired a resistor between that pin and 5V, the pin would go to 5V(on) when the sensor was floating and it would go to 0V(off) when it was tied to ground. You don’t actually have to install a resistor though. Because the chip can be configured to use an “internal pullup resistor” on that endstop. You need to enable that in configuration.h. I’m on my phone, but if you search for pullup, it will be there, and you can enable it for one specific pin.

I will try the pullup.