SKR 1.4 Turbo firmware help

I think I had a loose connection on my endestop, I changed it and no more Z axis probs…

Ok, tried some more movement, I don’t observe the problem at 100mm movement, think it is to little…

Moved to 1000mm and back a bunch of time

It slips 1 to 2mm each time against higher X value. Did not have more time.

This makes no sense.

What board, and drivers are you using, how is it wired up. How fast are you trying to move?

Skr 1.4 turbo, tmc2209, expertsnoobs dual endstop firmware, have not changed much…
Fan0 to neopixel pin…m
Maybe some stepper settings, come to think of it, I am at 72 steps pr mm, might that be my problem? That’s what I calibrated to for getting the right movement…

G92 X0 Y0 Z0
G0 Y1000 F1200
G0 Y-1000 F1200
G0 Y1000 F1200
G0 Y-1000 F1200
G0 Y1000 F1200
G0 Y-1000 F1200
G0 Y1000 F1200
G0 Y-1000 F1200
G0 Y1000 F1200
G0 Y-1000 F1200

Measure to make sure that it actually moves 1000mm, 72steps/mm is not correct. Also since it is not my firmware what is the current set at and what steppers are you using? Is That firmware set for 2209’s or 2208’s?

I expect my gcode above to work as expected. The rest is only if that is not working.

how many teeth does you pulley have ?
and how many micro steps per revolution on your steppers ?

For my setup pulley 20 teeth, steppers 200 micro-steps my settings is 80 steps per mm
For recommanded V1 setup its 16 teeth pulley(same 200 micro-steps steppesr if i’m right) and it must be configured at 100 steps per mm
For complete formula read that post :

Maybe your belt is broken or stretched? You don’t have the white steel core belts do you? Those work harden and break.

That doesn’t quite explain the backlash though.

It dos move 1000mm positive, 998-999mm negative…


Current is set to 800mA
microsteps: 16
I found something that looks odd, “Default axis steps per unit” is set to 143 for X and Y, and 800 for Z. For Y i have similar step pr mm of 72 to get thing right…

As far as i can tell (noob) the firmware is set to TMC2209 driver. All the defined drivers in config.h says TMC2209, not sure where else to look?
My steppers are Nema 17 Bipolar 1.8deg 65Ncm from Stepperonline.

I will check my belt thoroughly and the wheels…

You used my gcode with the slower speeds?

There is no firmware way for it to move differently. So the options are, moving so fast you skip a step at the turn around do to extremely poor accelerations, loose grub screws, broken belt.

I have not checked that firmware but 143 steps per mm makes no sense to me. 2mm belt, 16T pulleys, 200step/rev steppers, 16or 32 micro stepping. You should be at 100, 200, or 400. Our SKR Pro with 2209 uses 100x, 100Y, 400Z.

I just checked, that firmware is set at 200,200,800. What size pulley do you have that you changed it to 143?

That firmware is also set to 800 and 900 for current. I think you have something fishy with your firmware, you might want to start fresh.

I have no idea why it is set to 143 in my version…
I think you are right about starting over, i was clueless when i started fidling around with that firmware…Not that i have become an expert since but not as clueless :wink:

1 Like

X2 is at 800ma and 16 steps, vs the rest at 900 and 32. That needs to be fixed.

Is your Y axis fine and X axis messed up?

I have some belt issues with Y so have not checked that yet…

All my axis are set to 800mA, 16 steps…

And the firmware is set to 900 and 32, so I am not sure you actually have that firmware on your board.

You are right, i downloaded it again, and its much bigger now :thinking:

I am now sure it is firmware related, it consistently jumps on x and axis, i now tried lightburn and my laser, engraving a square, then a circle and then a hexagon that intersected, and it consitently jumped 2 mm in X dir and 12 in y going from layer to layer …

So any recomendation to the easy way to configure new firmware? I am out on deep water :man_swimming:

The Expertnoob firmware has endstop normally open, i would change that…
Not sure if my laser works without setting FAN= to the neopixel PIN?
But that should be the only changes i need?

Or is there a better choice?

What speeds are you trying to use? Too fast and odd things happen.

Oh, and test using the test crown. This could very much be your Gcode so let’s eliminate that.

Sorry I missed this part. Flash it as is and make sure it works for the basic motion, leave out endstops and lasers at first. If it does, make one change and reflash, test again.

Very slow not sure what the default speed in Lightburn is, but looks like few mm/s…