SKR 1.4 Turbo Noob Questions

Hello, everyone. Great forum here with a lot of information.

I’ve got my MPCNC build together with dual endstops. I have a 1.4 Turbo board and I’m trying to get firmware uploaded but I cannot get anything to compile. I have the 2209 drivers and want to use a Z probe.

I think I have a configuration.h all set up and ready to go but I keep getting errors when I try to compile. I even downloaded the latest version of Marlin and tried to compile it before making any changes and it still errors out in VS Code. This is my first time using this software so I’m sure I’m doing something wrong.

I have been searching online, this forum and YouTube on how to get this to work and I think my brain is getting overloaded with all the info out there. Does anyone have any tips or links to a few good tutorials on how to do this? Or, if anyone has this setup and would be willing to share a firmware.bin file that would be great too.

I do want to figure out the programming side of this, but I’m also getting anxious having a built machine sitting next to me that I can’t get moving right now.

Thanks in advance for the help.

I had problems getting things to build properly on Ardruino’s IDE but no problems with Platform.io in (I already was using Atom on the Mac for other development). I started by loading the SKR’s SD card directly on my computer but later figured out that a USB cable to SKR board’s USB port works also.

I did my dual end stop CNC build shortly before Marlin 2.0 was released and Ryan had a specific branch of Marlin for the dual end stops then… but pretty sure things have caught up since.

You did download the firmware from GitHub linked here?


https://docs.v1engineering.com/electronics/marlin-firmware/

and this

Thanks for posting this. I’ll take a look at it. I was able to get a version of the firmware compiled and running yesterday. The main problem I was running into was learning how to compile the code correctly since it was my first time ever doing a compile and using VS Code.

I think I have everything working, including the dual endstops and I was able to make my first crown! There’s still some tweaking that I think needs to happen yet to get my Primo to 100%, but it’s great to finally see a heartbeat.

The second thing I want to tackle is getting my TFT touch screen updated to be like some of the custom configurations I’ve seen. That looks quite a bit more intimidating and something that will need a lot more research before I dive into that one.

that first crown is satisfying … have fun carving!

1 Like

I noticed from the marlin side that it tries to launch platforming from the build directory. However if you are using windows, it has no concept of the path for that exe so it won’t compile.

You have to add that folder and exe to your system path and reboot.

I’m having the exact same problem you stated, with not being able to compile for the same SKR 1.4 Turbo board, what did you finally do it fix it? Did you have an issue where the little check at the bottom of VS Code to compile would just disappear? I’ve been stuck for a week, anything would help.

That check is from the platformio plugin. Are there any error messages in the bottom right about it? You can try restarting it, opening the platformio home and opening the project through the platformio interface. Worst case, uninstall it and follow the instructions from the top again. But it sounds like either platformio isn’t installed right, or the project isn’t open as a platformio project.

I’m pretty sure I had the board listed incorrectly. I was getting pin errors when compiling. When I finally got the board listed correctly it compiled and is working.

This is what I used for the board definition:
#define MOTHERBOARD BOARD_BTT_SKR_V1_4_TURBO

Hope that helps you out.

Tried all of that, reinstalled VS Code and everything, still no check, and no errors,

When I try to build using the terminal drop down and run build task I get the error pictured under

In that second image there is a button that says, “open project”. You need to open the project by selecting the folder with the platfor.ini file in it.

Much appreciated, that was indeed my issue and I was able to build the firmware, thanks! Now I have another issue, most likely once again down to my noobness, I have set up the pins as instructed to free up drivers, I set E0 to unused pins (P2_05) and E1 to E0 and E2 to E1, what I’m confused about is how I actually get those drivers to drive X2 and Y2 is that something I have to do in programming or do I have to do that on hardware?

1 Like

Where are those instructions? Those are old. You can leave the pins alone and set EXTRUDERS=0.

If you start with the skr pro dual firmware from marlinbuilder releases, it has dual endstops configured already. You need to just change the board type and possibly driver type.

I got that from the V1 website, at the bottom of the dual endstops page under software. I’ve tried using the SKR pro dual firmware, as well as a few others as a platform to start and changed the board, processer, drivers etc. but always ended up with literally dozens of errors.

  1. Thanks for the pointer. I should review that page in general to make sure it is up to date.
  2. The number of errors is not a good indication for how close you are. The first error is all that matters. The rest are often repeats or related to the first one.
  3. It says there are not enough drivers for Y2. The skr turbo has E0 and E1 defined, right?

There was another user recently that was trying to get the akr turbo to work and I looked at it. The endstops are a little strange to me. But another user stepped in with some firmware.