SKR Pro 1.2 firmware - correct motor plug position

my MPCNC Primo build is finally approaching it’s end. I used four endstops on x and y and bought a SKR Pro V 1.2 & TFT35 V3 E3 screen.
So I should probably be using the firmware “V1CNC_SkrPro_Dual_2209”.

Is this firmware “set for EXTRUDERS=0”?

Here it gives me three different options to connect the motors. I would like to know in advanced where to put them without experimenting around.

And another question: How do you guys start your gcode? Via SD-card or a connection via Laptop and something like pronterface?

Greetings, Michael

The newest (513) firmware is set EXTRUDERS=0. from the left with the stepper connections at the top of the board, it is X1-Y1-Z-X2-Y2, if a motor is running the wrong way on test, just flip the plug on the board 180 degrees.

So the stepper motors should be plugged in as in pic 1 in the docs.

I use a USB stick in the TFT and also run occasionally via laptop using CNCjs plugged into the SKR. Some people use pronterface.


Important: do not forget to turn off the power before disconnecting a stepper cable…

1 Like

Thank you both, it works.
Quick follow up questions.

  • By increasing the Value of Z, is the axis supposed to go down? Or do I need to switch it around?

  • I want do use my 4 endstops to home and calibrate the machine. I’m unsure what I do in this menu: “Motion → Soft Endstops” Do I leave it at “on” or do I turn it off?

Positive Z goes up. Positive X goes right Positive Y goes away from you. If you can stand anywhere and have that be true, then you are ok. But your cam will be from that vantage point.

Soft endstops make the machine limit itself based on the BED_SIZE in the firmware.

Thanks, I did my first tests and it’s working great.
I got some more questions. I hope it’s okay to just ask them here instead of starting another topic.

Am I correct, that to change that, I have to change the firmware and upload it again? Meaning: No way to do it on the Display.

  • I connected a touch plate. When homing X Y and Z, my Z is zero allthough it’s on top of the touch plate. So somewhere I have to tell the software how thick my touche plate is.
    I put a seperate gcode on my SD-Card ( G90 G28 Z M400 G92 Z7.900 G0 Z40.000 ) and that’s working but if I have a job with a toolchange i would have to manually adjust the gcode.
    There must be a simpler way.

  • Also: My touche plate is of the x-y-z-kind. I’ve read many threads regarding making it work but I never now how software-specific that information is.
    Is there a not too complicated way to implement an x-y-z-touche plate with this board and software? Or is it done in fusion in the post processing?

  • is there a way, to move the machine to a certain point and then set the Z value to zero?

It’s all a little bit overwhelming at the moment ^^

Yeah. Because of that, it isn’t really worth it.

I’ve not seen that work without a lot of work. My main concern with them is that it doesn’t account for the angle in X or Y.

Yep. G92 X0 Y0 Z0 forces the current location to zero. You can do it just to a specific axis, or all three. There is more info in the coordinates section of the docs:

Take it one step at a time. The easiest thing to do is to just put G92 X0 Y0 Z0 at the top of your gcode and start your gcode where you want the origin.

The next easiest is to set up gcode files, for setting X0, Y0, Z0 and all three and just set up the job before starting the gcode.