SKR Pro 1.2 firmware

I am having difficulty flashing the firmware on the SKR Pro 1.2 board. The stock firmware works fine and I have no issues reverting to it however whenever I compile any of the MPCNC versions and flash the board it is not responsive. It doesn’t show as a COM port on my laptop and the TFT won’t connect (shows no printer attached). The board is basically bricked whenever I flash it. Has anyone had any luck compiling Marlin 2 for these boards and using them? I’ve worked with Marlin upgrades before on my Ender 3 and didn’t have any issues. My main reason for wanting to change firmware is for dual end stops but a always like hacking devices to play with advanced features. Everything works fine when I revert to the stock firmware. I’ve tried with nothing but the TFT and power plugged in, with it wired properly for dual endstops, with it wired for series, and even played with moving the stepper drivers around, swapping them around, changing to extruder = 1, and various SKR 1.2 versions from the Github repository including the standard and dual end stop firmware. Any help would be greatly appreciated.

The firmware in the MarlinBuilder releases comes with the firmware.bin already compiled. You shouldn’t have to build it. Are you sure you are using the skr pro firmware and are you sure you have an skr pro board?

I have tried the .bin files too. It is an SKR Pro v1.2 that I just got about a week ago from V1. The only firmware I can get to work is the preloaded one that was also on the microSD card that was in the board when I received it. I can use that firmware with no problems. I’ve tried 10 or so itterations of Marlin source files to build firmware. I have not tried starting with a scratch build of Marlin straight from the Marlin repository yet but probably will if I can find the time today. I’ve built my Ender 3 firmware from that source with no issues. It doesn’t seem to be a build issue as precompiled firmware gives me the same results.

Weird. The skr pro firmware is tested. Which version are you trying? v508 has worked on a ton of boards.

I wonder if it is something with the gray tft cables. The stock firmware doesn’t have that screen enabled, but all the v1 ones do. You can remove the gray cables. Or better yet, remove the tft completely and check over USB.

i had a problem once with changing the firmware. i unplugged the grey ones and never plugged them back. i was able to flash no problems.

1 Like

That was it! Thank you!!! Now I’ll recompile and add TFT support and see how it goes. I don’t want to have to use my Alienware laptop to drive my CNC.

Now I can home this thing in for some precision milling. I never thought the TFT would interfere with getting it to load firmware. Once I got it flashed and plugged in the TFT everything still runs fine it just doesn’t let me control it from the screen.

Is there a reason the TFT is disabled for the dual stop firmware that I’m overlooking?

The marlinbuilder releases firmware has the tft enabled on the skr pro builds and you shouldn’t have to compile it at all. The readme sort of shows what we configured (but it is dependent on our attention to detail :man_shrugging:). There is a .git in there and you can see exactly what we changed with git, but we delete a bunch of HAL files to make the build work better in windows.

All that is to say, I am pretty sure the TFT is enabled in our firmware. It should connect at 250k.

The next thing to try is to make sure the gray cables are connected the right way. You should be able to leave the gray and the black cables connected all the time and use either marlin mode or tft mode. So something is either broken with the screen, or it wasn’t wired right.

The source has it enabled so I’m guessing the precompiled firmware does. I’m not getting a connection. I did see some people had to trim the tab off one of the connectors so that it could be connected backwards. I haven’t tried that

It is baffling that it wouldn’t flash properly with the screen connected. With the stock firmware I was only able to use the touch screen so maybe my issue is with the screen.

This “can’t flash firmware with EXP cables connected” seems to be a common problem across multiple boards and TFTs. Both with flashing the board firmware and the TFT firmware. Is this something that could be put in a FAQ section. Also @vicious1, does Big Tree have any input on why this happens?

Does it only happen when trying to flash over USB or from the micro SD?

From what I have experienced personally, and what I’ve seen in the forums, it’s when flashing from the SD card. I have personally encountered this issue with the SKR 1.4, and 1.4 Turbo boards, and the TFT24 screens. One or both wont flash if the EXP cables are connected.

1 Like

We have always had issues with the gray cables being installed backwards. I think the boards don’t have consistent keying, so that really hurts people’s chances.

The new thing is that wiring it wrong on the skr causes it not to boot, and some people have reported it goes to the screen type choice menu after 10 seconds and never responds. These symptoms are new, but the issue of plugging it in wrong is very common.

Some kind of faq would be good. But where?

1 Like

Well I can at least put up a sentence on the SKR docs page to start.

1 Like

My thought would be in the forum root. Kind of a “Look Here First” or “Common problems” pertaining globally to all machines. These would be issues that happen a lot and have relatively easy fixes. Think grub screws and backwards cables. It would be a static list maintained by probably you and Ryan, but driven by reports in from regulars and your run-ins in the rest of the forums. I dunno, any other thoughts?

1 Like

I just added it, lets see if that helps out first. I know I had that issue before when testing and forgot all about it though.

I finally got it all figured out. The cables are keyed correctly but the default baud rate was wrong. What is weirdest is that it would let me flash the original firmware but no others with the TFT installed but set the the incorrect baud rate. I haven’t flashed it since getting the screen working properly so maybe it will flash now. I flashed using the provided micro SD every time. This is the first cut after flashing and getting dual end stops running. Ot looks like the circle is a little wobbly but it is actually the .jpg I used to make the dxf I based the cut on. Now to make some jigs so I can lay out some repeatable jobs.

1 Like