SKR Pro 1.2, newest firmware, 513, issues

Sometimes it is better to leave things alone than to try and upgrade the firmware (which added some features I thought would be good) on the controller board (SKR Pro 1.2).
After much frustration with the newest firmware version, I reverted to the known working, year old, version.
Add the additional frustration of an updated post processor for the design software, you have a multiple issue failure scenario.
After reverting the firmware and reloading a known good post processor, on (12/8/2021) I was successful in cutting a “in the air, router off” tool path.
I have 2 MPCNC Primos, with different footprints.
As a test, I loaded a known good firmware for my setups, 509 v 2.0.7.2 version, to the newest MPCNC. Ran a cut gcode, worked fine.
On the older MPCNC, I left the new firmware, 513 v2.0.9.2, on it and ran the same cut gcode. Failed. I’m no Marlin or firmware guru, so with that, both machines this AM will be running the 509 firmware, and the TFT35 touch screen firmware (SKR Pro1.2 on both. I’m a data packrat still had them).

Posted to see if there is a workaround/fix, or an update. Reporting my experience with the firmware, as I was wanting the arc support the newest firmware has.

Can you explain what was wrong with v513?

Hard to describe, but I’ll give it a try.

Both machines using SKR Pro 1.2 with LCD, running off microSD card in the LCD35, both machines controllers and LCD’s from V1. The gcode file is 328KB, all profile cuts. Tool paths generate on Carveco Maker, with post processor that I have been using for over a year, no G2/G3 arc moves.

When cutting, on 2 different MPCNC’s with different bed sizes, the tool path stalls then takes off in a random direction. Initially I thought it was a power drop issue on the newest build, so I load the 513 firmware on the year old machine. That machine has a dedicated APC Line-R voltage regulator on it. Results the same.
Appears the trouble occurs at the 50-70% gcode run, when doing a circle profile cut. I rebuilt the gcode file several times to slow and change the stepdown, nope. I tried reducing the speed to 30%, same results. Tool path time is 38 minutes, 1/4" down cut bit, 30mm/sec rate, 0.2mm step down. Stepper motors and drivers warm but not hot. Both machines have ferrite toroids on the cords to the routers and the Z axis

The year old MPCNC I have pushed a lot harder, up to 120 in/min, with 1/8" step downs with 509 and 510 firmware. I had posted a video last year showing the older MPCNC cutting the same parts. 45 planks, 9:30 min runtime, 1/8 inch step downs, zero fails on the FaceBook forum.

1 Like

Thanks for sharing.

Are you using the try in TFT mode? Ryan and I have been trying to reproduce some stalling or noise issues with the tft firmware.

My theory is that because of the inherent design if the touch screen mode, it is more susceptible to noise than Marlin mode. Ryan yes v513 and the Marlin mode in his farm. But when he did a few jobs in touch screen, he saw some jobs stalling.

TFT mode, yes

I’ll try it with a laptop this afternoon, on MPCNC 2. And with the Raspberry Pi 400 on MPCNC 1. Will re build the gcode file, with and without arcs for a test as well

You could also try Marlin mode with the TFT.

Testing update 2:00 PM CST.

Ran gcode on MPCNC 2, gcode on SD card. Run stalled out at 60% complete, speed at 50%

Ran gcode in “Marlin” mode, Run stalled at 78% complete. speed 100%

Hooked up laptop, disconnected LCD. Started gcode run using CNCjs, same gcode. Ran 3x, run #1 at 50% speed, run #2 at 100%, and run #3 at 200%. No stalling, or skips in all 3 runs, completed no matter speed.

Now to find those oddball ferrite toroids I have and put them on the LCD cables for the next test. Which will be LCD connected, gcode off of LCD

2 Likes

Did you update both the SKR & the TFT, or just the SKR?

Both

Jeffeb3

Testing on MPCNC #2 completed. Firmware 513 loaded. Newest TFT35 (TFT_E3V3_1_7_2.zip from the SKR Pro page) firmware loaded.

Ferrite toroids added to the EXP 1 & 2 cables, and to the black cable on the TFT.

Testing revealed an issue.

The screen will load the gcode from a USB on TFT35 stick/MicroSD USB adapter stick (The way I have run my machines for a year). During run random stalls occurred during 5 tests at different speeds. When ran from a SDCard (slot on TFT35), no stalls in 4 test runs. Issue tracking to TFT firmware/streaming speed. USB adapters/USB sticks tested and verified good. MicroSD cards tested good.

Tests streaming from CNCjs, and Repetier have no issues.

Just from TFT35 USB slot does stalls in gcode stream occur

1 Like

This is very surprising.

This is not surprising to me. I think the screen is the problem.

The exp1&2 cables are only needed for Marlin mode. The black cable is only needed for TFT mode.

This is also weird. I haven’t ever tried the USB stick, but I would not have expected any difference.

I will have to think about this for a while. I am pretty sure the v513 isn’t the issue and the problems are all in the screen. I have a dummy setup on my desk where I can try it, but inspect the comms in TFT mode. If you share your gcode with me, I can try running it to see if I can see it stalling.

1 Like

5bobb12.10a.gcode (381.2 KB)

I did read somewhere in the last 2 weeks someone was having USB stick issues with a TFT35, on a 3d printer though, BTT’s firmware

1 Like

I am running the latest FW on my LR2, and only use USB stick as SD cards get damaged easily.
Did 3 cuts the other day (±1,5h) without an issue. So I doubt that this will be a bug/issue.

I would try to swap the SD to USB adapter to a real usb stick, to see if the issue occurs in the adapter.
The adapter uses some pins to clamp the SD to the USB stick. The machine vibrates during production, so maybe the adapter stick is wearing out due to vibrations?

just an idea.

1 Like

Yep tried that, straight old USB stick, still stalls

Weird! And does it work with a stick plugged in to the SKR?

I’ll admit, I haven’t tried it that way on the SKR usb port, not had a lot of luck with it over the last year

First off this round was checking all the bolts, bearings, belts, pulleys, etc. All good on MPCNC #2. MPCNC #1 had some issues I had not found until this complete inspection. Repaired/adjusted MPCNC #1.

  1. Re-routed the router power line MPCNC #1 & #2. It has ferrite toroids on it, but eliminate possible RF signal interference with Z Axis line.
  2. USB Stick plugged into SKR: TFT took several attempts to open it. I wasn’t totally confident in it given the long delay to read, so I didn’t do a router off test.
  3. Cut file is very conservative compared to other jobs I have done. Step down is less than a sheet of paper with a conservative 30 in/min feedrate. Previously have done 1/8" step downs at very high feedrate of 126 in/min.
  4. Wood that was being cut during this process was Hard Maple (Janka hardness 1450 lbf), it is almost twice as hard as the cherry I usually cut. Switched out wood to be cut to cherry (Janka 950 lbf) to reduce possible load.
  5. SD Card (not a microUSB adapter) plugged into TFT: Worked at 100% speed. Completed actual cut on cherry wood at 100% on MPCNC #2.

A friend has a RF signal detector and is bringing it over this weekend to check signal interference in the shop, and when MPCNC’s are running. The stepper lines, and other wiring is fairly long.

2 Likes

OK, both machines sorted and running 513 on parts yesterday. Still have the issue of the USB on TFT35 randomly stalling. Running off SDcard slot in TFT35. Posting vid to Facebook group.
RF scan Saturday was very low interference.

2 Likes

Just out of curiosity… Do you have the SD Card inserted in the SKR Board(not on the TFT but the board itself)?
Try to run the board without it…
I had problems with my “Repeat” when the SD Card was present.