SKR Pro 1.2 Zprobe

I installed bltouch probe using 3D touch, it shows Z triggered but never stop Z homing, I could not find the way to make it work. Anyone know if SKR only works with the original BLtouch? And also the Z Offset is saved on eeprom but after homing it goes out. I have to set it again. I try Bltouch probe on Zmin plug, I tries on bltouch plug , I change Zmin pin to PA2. Nothing works, I got frustrated because on videos it looks so easy to make it works.Any help will be very appreciated.

I can’t comment on the SKR Pro board, but I have had nothing but trouble with the BLTouch and my Ender 3 Pro.

I never got it to work correctly on my printer as there are different versions of the BLTouch V2, V3 and V3.1 (IIRC). There may be more and they work different and have different voltages. I rebuilt the firmware and was in touch with a number of other people to get it to work. None of us managed to get mine or other peoples BLTouch working. We all put a lot of time in, looking at code and trying to debug it. The behaviour we found was that the BLTouch would work for the first few points and then for the next probes would just try and zoom over upwards on the Z axis. I suspect a memory overflow that switched a value from +ve to -ve but we never found it.

On my printer you connect the BLTouch and ask to level, it then goes and does a quick touch, then drops more gently to provide more accurate information. The colours change on the BLTouch to indicate what is going on. I don’t remember the colour sequence. Do you get that behaviour or are you using it as a Zprobe in which case it’s an expensive Z probe that can be made for about 50p or 50c (if that). My Z probe consists of a crocodile clip, some wire and a piece of thin flat steel I found lying on my workbench.

I suspect you will need to provide a lot more information on what you are trying to do, e.g.

  1. Which exact version of firmware?
  2. What changes you have done to the firmware?
  3. Where have you connected it on the board? I recall some boards have dedicated BLTouch ports.
  4. Which version of the BLTouch do you have? This is tricky to find out for some versions.

I suspect there are other things needed, but that’s a good starter.

Thank you Rob for your prompt attention.
Firmware is Marlin 2.0 bug fix.
I followed all instructions to change when installing bl touch.and when it did not work I start doing a lot of others changes, like pins, connection on Z_min, etc.
I connect to dedicated plug on my board Skr pro 1.2. and tried signal on Z_min.
my bl touch is 3D touch V3.0.
the probe looks like it is working, it deploy and lights flashes, and you check with M851 it shows Z triggered, but the board to not stop. I am having the most hard time to put this board to work. I don’t know if is a good one, because nobody talks about this board skr pro 1.2, is seems just me have this one.

I have a feeling that Marlin 2.0 Bugfix doesn’t support the BLTouch out of the box (no matter what it says) and you need to set the firmware up properly.

Here’s all the different versions I tried to get it working

image

This is the site I spent thye most time on to get it working

https://www.danbp.org/p/en/comment/896#comment-896

though this site this was very helpful

https://danielstanton.co.uk/357/configuring-marlin-2-0-for-an-ender-3-pro-and-bltouch/

Danbp (the first site) was very helpful and we spent a lot of time to get it working (though we failed miserably, he’s not to blame just to be clear). If you look through the comments you’ll see me as I’m the same rwillett.

If you are doing this then you need to download platform.io and get that working. If any of the firmware versions I use might be of help, let me know and I’ll send them to you.

You don’t say what you are doing this on, a printer, a MPCNC, a low rider?

If its a CNC machine, I’m not convinced it’s worth it and far more cleverer people than me have advised me not to. I also don’t use it on my Ender 3 Pro and have no issues printing. It’s quicker for me to level by hand than using a BLTouch. If you have a print bed this is very concave or convex, just level the bed for that area.

I’ve pulled my BLtouch off the shelf and realised I wasted £40 buying it :slight_smile:

Rob

I jave an skr pro v1.2 and I think it is a good board. There isn’t much that would be the board’s fault when working with a bl touch. Don’t beat yourself up.

Marlin bugfix 2.0 is a moving target and frequently doesn’t work. Using 2.0.6.1 is a better starting place.

I use a bl touch on my printer, which uses a skr not pro 1.3. The bl touch works fine.

The 3d touch does cut some corners and I find it very hard to debug because you have to check thing within a certain time.

I have had very good experiences with mine. Don’t be discouraged. I am sure it is something simple.

I would start with a clean 2.0.6.1 and keep a good record of what settings you are changing in the firmware. You should be able to do it in steps. Set it up without worrying about the bl touch first. Then enable the bltouch and test that it can deploy and M119 shows triggered. Then home Z. Then worry about bed leveling.

Is this on a printer or a cnc?

@jeffeb3

The BLTouch’s appear to vary with both 3.3V and 5V versions. The older one seem to work better than the newer ones (as far as I can tell) but since the documentation on what you have got is very, very poor, its difficult to work out. My BLTouch has no version information at all, it simply says “Works with Creality V1 mainboard”. However it’s not clear what a V1 mainboard is (or isn’t).

There’s an awful lot of misinformation on this on the intertubes with most of it contradictory and very confusion. The two sites I quoted were at the end of a long investigation and then an even longer set of tests. I’d set it up with a nine point grid, it would do the first six points and then on the third row, the BLTouch would constantly go up and never come down. Six points were set up correctly, 7th was wrong.

I don’t want to put people off, but some BLTouch’s are tricky and it’s a PITA to take them off and put them back on the Ender 3 printers. YMMV. It appears to be lottery which ones work. if you look at the comments section on

https://www.danbp.org/p/en/comment/896#comment-896 on the site, there’s a lot of good work going into trying to work out what the issue is.

Anyway, hopefully the OP will get his or her’s working, I might then try and get mine working.

Thanks

Rob

I don’t deny you your pain at all. But your issues are not everyone’s issues. I have used them for more than a year, on several installations and I haven’t had a problem. I did only use one “3d touch” and the other three are all legit bltouch sensors.

The SKR pro will handle it just fine. Especially if you are getting TRIGGERED when you are supposed to, I think you are close.

@jeffeb3

Everybody is different and I hope that the OP gets it sorted out easily and quickly. They may be able to learn from the issues we had (and there were a number of us, it wasn’t just me).

I am still happy to help where I can but I don’t have the same MB as he does. You do, so it might be an easy journey.

Rob

hello , I am new user but I want t to help . I have a SKR pro 1.2 and 3D touch work perfect wit Marlin version 2.0.3
configure how skr pro 1.1
go to SCR -Pins - stm32 -and change #define Z_MIN_PIN PA2 equal that #define Z_MIN_PROBE_PIN PA2
same pin
connect 3D touch in connector of BL touch . Now 3D touch is z_min_pin and z_min_probe_pin at the same time.
marlin 2.0.7 problems with PID hotend , other vesions I dont know. Remember I work with marlin 2.0.3

Juan, my BLtouch worked fine with my SKR Pro v1.1, up to Marlin 2.08. I had to replace my SKR pro V1.1, and I decided to get the SKR Pro V1.2. Now the BLTouch is not working. It deploy & stow 2 times when power is applied. Thereafter nothing. M401 & M402 has no effect.
Could you upload your Config.h, Config_adv.h and the pins_BTT_SKR_PRO_common.h files?
Thanks
Ian