SKR Pro v1.2 no usb, no printer attached error

All was going well, I have been trying to configure the endstop pins for dual z and dual y switches and it was coming along. I had gotten it figured out then the USB connection dropped and the TFT started saying printer not connected. I had earlier had same problem with the TFT and changed the baud to 250000 and that had fixed it, but that was not the issue this time. I can no longer get the SKR Pro to connect via usb to pronterface, either on mac or on windows, the TFT says ‘no printer attached’ and the Marlin interface screen is not working either. Checked the fuses on the SKR Pro and they all seem fine. Visually the board looks fine and I was very careful in handling it, powering it off before changing any pins and so forth. Checked the voltage coming off the green doo-hicky and it’s showing 12 volts. I re-downloaded the clean firmware I started with in case it was something I changed in the code, on both for the TFT and the SKR Pro but still no luck. I downloaded the firmware a few times to be sure, but still not getting it to see the printer nor the usb connection. It is frustrating because I was so close to getting everything the way I wanted, it was working fine and now this. Tried searching the forums but could not find any specific answer this time so starting this thread.

Is the board powering on? Lights on?

Have you tried disconnecting everything except power? Try with only the grey LCD cables? Only the black?

The SKR board lights up, blue light near the usb, three orange lights in the middle. When flashing the firmware the lights flash as expected too. The LCD cabling has no effect, I tried all combos and no difference.

Does the firnware.bin change to a firnware.cur?

Yes, it does

My guess is that the hardware is fine. The software comes in two pieces:

  1. The firmware.bin is the program we care about, Marlin.
  2. The bootloader is in charge of replacing the firmware.bin and then booting into it each startup.

The bootloader may be broken, or the firmware isn’t being flashed right. Maybe another sd card? If all else fails, you may want to flash the bootloader. That is the sledge hammer approach.

FWIW, flashing software via the bootloader is not supposed to be able to corrupt the bootloader. Which why we usually don’t have to mess with it.

Also FWIW, I may be more pessimistic about the BL than anyone else. It may be something else.

1 Like

I am using the clean firmware.bin that worked before and I am getting the .CUR ending after flashing every time. I have tried a few times now but still no go. I do not have another SD card but I suppose I could go buy one to try it.

How do I flash the bootloader?

I flashed it using a usb to uart adapter. I know there are a bunch of ways to do it. But I found some tips in a random github issue thread.

It is a more advanced thing to do. So if none of that makes sense, it might be better to try everything else first.

Well the usb port is not working now so this might be a thing to try. If I can get the adaptor what am I flashing, the same firmware or something else?

Anthony… Having same issue as you. However won’t flash to .cur. Following for bootloader steps.

@jeffeb3 Would this work? Totally out of my comfort zone of expertise now. https://www.amazon.ca/Adapter-Serial-Converter-Development-Projects/dp/B075N82CDL Will order if so.

How to flash the bootloader.

@aleonardo

1 Like

OK, thanks. Your link was to Amazon Canada, didn’t notice and they said they could not ship to me. lol, changed to US and will get it tomorrow then I will give it a try.

Yeah. That is what I am talking about. That is one of the pricier ones (unless I missed some inflation somewhere). I believe you can also make one from a regular arduino, but I have not tried it myself. They are very useful tools.

It has been a while, and I just skimmed that video. But it looks right to me. I believe you need to make sure you do not power the skr from the regular power. I couldn’t get st link to work in linux, but there was an open source command line version.

This is why I didn’t want to describe it in detail, I have an advanced set up.

If you are not getting it to change to .cur, then I would look more closely at the power and the fuses. Those are not the same issue.

the firmware file does change to .cur but not seeing it via usb in pronoterface and the TFT screen says ‘no printer attached’

This is confusing, because Marko is jumping in with different symptoms.

Yes, it loads the firmware and I get the .cur file afterwards but just no connection to the TFT and no connection via usb. Do you still recommend flashing the bootloader firmware?

I understand your symptoms. I was responding to Marko, which is how you got confused.

I don’t think I ever recommended it :). I just suggested that it may fix the issue. I also said, you should do that only after you’ve exhausted the other options.

1 Like

I just received the link adaptor that Marko recommended and the pin labels do not match up with the SKR. I do not think it is the correct one. I ordered the St-link referred to in the video and will get that tomorrow unless someone knows it the pins translate to what the board says. The link I got today has pins labeled CTS, RTS, RXD, TXD, GND, VCC. The SKR pins are RST, SWC, GND, SWD, 3.3.

The uart pins I used are on a little 4 pin bus, near the reset switch labelled UART. From the board you just got, it would be the GND, VCC (3.3V, IIRC), TX, RX. But probably not in that order. I would have to look it up.

Is there anything else you can try before flashing the bootloader again? :slight_smile: