SKR v1.2, TMC2209, TFT35 Problems

Hey guys,

I just built my LR2 CNC with the above mentioned Parts from the V1Shop. Assembly wasn‘t a problem till now.

Today I setup all parts and wired them together. Following the instructions of the build page.

Software ist the one with 2209 Dual Endstops for the LowRider, incl the mentioned TFT Firmware of the Buildpage. Now there are two errors left.

First:

I flashed the both firmwares but the Icons on the TFT are messed up. They Buttons work correctly i think but the pictures are messed up. They look like they al are shifted up. So that the Icon shows two halves. One half seems to be correct the lower half shows a part of the icon of the second row. I hope you do understand how it looks like.

The second and bigger Problem is that one of the Z Steppers is always working in the same direction. No matter if i push Z+ or Z- it always lowers (its the Z2 Stepper) The normal Z-Stepper is working fine. All other steppers do also work like they should.
Because of this I tried to change the drivers and and i changed the Z1 und Z2 wires. No Change it’s always the same Stepper. No Matter if I plug in Z1,Z2 or any other Axis.

Is the Stepper damaged? Or something wrong with the Firmware?
I didn’t change anything on the firmware. If it is possible, that the Firmware is broken, where is the Point to check? I’m not really in the Programming Part.

One question left. It should be a dual endstop LowRider. Is the error caused because there are no Endstops connected till now? If this should be a Problem, why is it only ONE of the five steppers?

Thanks for reading. I would love to see some answers.

Regards

This is most likely a wiring issue. Some people have had trouble with pre-crimped wires, so it might be worth checking continuity for pairs. If it follows the motor, then it’s most certainly not the firmware.

You can run a dual endstop LowRider with no stops connected. It will work fine, though homing will of course not work.

I’ve heard of some issues with “new boards” for the TFT, but this wasn’t one of them. It may be worth trying again, the firmware.bin file may have been corrupted on the SD card. This happens sometimes with SD cards.

1 Like

The wiring was made by myself. I will redo the wiring for this stepper.
Otherwise it has to be the motor… ill check tomorrow

I updated the firmware of the tft several times now. I think i will flash a completely different one and try again than.

Sounds like an endstop issue, actually. You can check them with M119, not a stepper thing. If it thinks an endstop is triggered, it will only move away from it.

As for the screen it should have been pre flashed from me. If it is a new one…in the last week then it needs new files. If it is an older one than it means you probably have not copied the images folder over correctly to the SD card.

If it is a new one let me know and I will give you the link…if it is older do not flash the new files as you can not go backwards. For now the older is more fancy.

I think this is a wiring issue. There are two coils and motion grabs one and then the other. If one of the coils was not working it would go from one spot, to completely loose (and drop) to the next spot, then loose. If you changed the stepper at the stepper, then maybe one of the wires is bad inside the stepper.

Steppers are really simple devices and they almost never fail. Wiring is much more commonly the issue.

This means, that maybe IF there is one line short (maybe in the Dupond Plug) this could cause this issue?

Have you tried the stepper plugged directly into a known good port, X for example? That would rule out a lot of things.

The wire colors on that stepper plug are in the same order as the rest of the steppers you have?

That would really blow my mind if it is a one way stepper somehow.

1 Like

More likely an open than a short.

Ryan has a good idea to try to skip the cables.

It’s only one way because of gravity. I am thinking of these positions:

A
B
-A <- -A above
-B
A <- It is here
B
-A <- -A below
-B
A

It is trying to go up, and coil B is doing nothing. So it goes from A to -B to -A. But it is only getting torque at A and the. -A. Gravity is pulling it down, to the -A below, instead of -B pulling it up towards -A above.

Just a guess. I have seen something similar before with an intermittent wiring issue on mine. It sounded like skipping steps, but not exactly the same.

1 Like

I see what you’re saying.

1 Like

Is it possible to control the stepper with a separate cable manually, maybe with a 5V port or something?
Sure it is possible that the wires maybe open or short. I will check the DuPont on the weekend.

Other possibility is there a way that the stepper hardware is damaged? As soon as i unplug the board this Zaxis is „falling“ down. (Gravity :-P) maybe something inside is broken.

To Ryan: I plugged the X Stepper to the Z1 Port and it worked fine. Need to check the other way around with the „broken“ Stepper in an X Port

Not really, no. You can check the resistance with a multimeter. Wires 1-2 (coil 1) should have a few ohms resistance and wires 3-4 (coil 2) should have a few ohms resistance. There should be no continuity between the coils.

The falling down is normal. Once this works, you should get in the habit of parking the machine in a home so it won’t come crashing down. That’s one of the reasons it is called the low rider. Steppers are a lot simpler than you think. They basically just have a bunch of coils in the middle around the shaft, some permanent magnets around the outside, and some bearings to keep the shaft in the middle of the whole thing. There are no gears and nothing really in there can break.

1 Like

Hey my Friends!

I could solve the Problem with the LCD AND the wrong running stepper. Seems that the wiring was off.

No the next Problem.

The homing doesn’t work.

As i start to home XY, the X axis homes correctly. the Y axis goes backwards and doesnt stop, even if both switches are triggered. I can see on the LEDs flashing on the SKR Board beside the stepper plugs.

Some with the Z axis. its running and running even if i push the triggeres by hand. Also both LEDs are flashing beside the Stepperplugs but they keep running.

Any ideas?

Thanks for the help till now

Use M119 to debug the endstops before trying the home command.

I got it working. i messed up the wiring again.

No i Hope we solve the LAST Problenm together. There is still an issue with the Z1 stepper? As soon the the Z axisses are to for off from each other the Z1 Stepper seems to “fall down” as soon i turn the spindle by hand up a little, the stepper catches again and the Z homing goes an till the end.

Is there maybe a damaged stepper? Or is there some kind of emergency off as soon as the tork on the stepper is too much?

A damaged stepper motor is extremely unlikely.

The TMC drivers have a “stall detection” mode, if that’s turned on, then the driver will signal to the board that it has stalled. This mode should be OFF if you’re using stop switches though.

im sorry for dumb questions like this. But is there a possibility to turn this protection off? And if the is please tell me where. Or should this be deactivated with the V1 firmware?

is it the M914 command?

The V1 firmware turns this mode off. I don’t remember the command to report the status, sorry.