SKR1.4 upload issues

Hi guys. New here and first post. I stumbled across this site searching for an issue I am having with my board. So I hope this is the right place to ask.

I currently am running an SKR1.4 turbo with Tmc2209 drivers. The issue I am having is that any new changes I make in my config files will not load to the board. I can see the changes in Marlin, it say it has uploaded, but the values are still the same on the board.

It seems this is a problem that has happened to quite a few other SKR owners. Wondering if there is an actual fix for this? Or some sort of work around to get it to upload.

I have tried the paper in with the sd card and that has not worked.

Which things are you changing?

Some settings are also controlled by gcode and saved on eeprom. To force all the settings to use what is in the firmware, send M502. To save those loaded parameters back to the eeprom, send M500.

Thanks for the quick reply. The things being changed could be anything. Like true or false for steppers, or offsets. It does not seem to matter.

I do the upload, then on Pronterface I do the M502 then M500. Then I turn off the printer and reset turning back on. I have changed some things right through Pronterface, but anything done through Marlin now will not take.

How are you uploading it?

I have tried both USB through the joadd and removing the sd card and doing right though the computer. Both time using VS code.

I think on the turbo, like the other skrs, you are supposed to put the .bin on the micro sd card and then power it on. You just need to compile in pio and grab the .bin to flash it.

You can find some turbo builds on MarlinBuilder releases. You can check the version running with M115, it should show something like v510D or v510S. See if you can flash one of those and verify the version.

1 Like

That is correct. The bin file changes to a .cur file then you know that the file has been flashed.

The running version is This has happened on every version I have tried. The marlin firmware I can compile, hit upload and says complete. Then I have to move to Pronterface to finish…using the M502, M500 commands.

The problem is when I go back and do an M503 the values have not changed. It is the same as it has been.

So even though it says uploaded, it has not uploaded to the board. There is a .cur file there now…it just wont update.

Just for giggles, try loading one of our firmware’s, see if things change, then try to load yours again.

I am willing to try. Not sure it will make any difference but I will definitely try. Where do I go for the firmware?

marlinbuilder releases

Thanks for the link. I noticed there is one for sure tested version for the SKR1.4 with the 2209. So I will test that hopefully tomorrow and report back.

Make sure you grab a turbo one, not one for the skr pro or skr 1.3

1 Like

Just to chip in. I had an issue with my Z movement so changed to z stepper value in Marlin and it never changed on the Turbo, even though the bin had changed to cur. My new 4 start leadscrew arrived before I sorted the issue.

Never tried the eeprom thingy but I didn’t deliberately save to eeprom either

Pretty much the issue I am having now. Doesn’t matter what I change, it changes in marlin and shows as being changed…but nothing to eeprom.

You don’t have to deliberately save to eeprom. The first time it loads, it will write the defaults to eeprom. There are three copies of these kinds of settings:

  • default in the firmware. This is the configuration.h file value.
  • actively running setting. These start from the eeprom settings every time you power on or reset. These can only be changed from gcode. You can load the firmware defaults with M502.
  • value in eeprom. Flashing won’t change this. You can save the active settings to the eeprom with M500.

The code running at each boot has no idea if it is booting for the first time, or the 10,000th time, so it isn’t possible for it to know you changed a default in the firmware. It is a limit of the hardware, really. It is confusing, I know.


Very confusing. I thought when I loaded marlin and did a M502, M500 that that would flash the firmare which does change the eeprom. I guess I am very lost.

It does. I was responding to Mick.

1 Like

Dang Heffe, I knew these things but that list seems to be very concise. Now I think I really understand it in a way I did not before. Killer post!! Can you think of anywhere to put it in the docs?

1 Like

It might fit into the learning/gcode page, or we could add a page for extra configuration. IDK.

1 Like

Thanks Jeffeb3, everyday is a schoolday.