[solved] Marlin 2.0 + Rambo + Dual Endstops + LCD (Buttons Don't Work)

I just finished the mechanical assembly of my mpcnc. I purchased the full-size rambo board, the dual end-stop kit, and the LCD.

I performed a clean install of Arduino 1.8.5, and added the Rambo Board. I downloaded the latest build of the Marlin 2.0 firmware for the kit I have (rambo, dual endstops, LCD, T8).

I started to compile and got the “Path Too Long” error. Per Ryan’s suggestions elsewhere on the forum, I edited the preferences file to change the build path to c:\tmp. That fixed the path error.

I then got another error " u8g_InitCom(u8g, dev, U8G_SPI_CLK_CYCLE_300NS);". In the same thread, Ryan suggested updating the U8Glib and re-compiling. I did that too.

Updating the u8glib allowed the compiler to run and upload the firmware. The boot screen flashed just like i’d expect it too (I have another Marlin 3d printer with the same LCD).

However, the problem is that none of the buttons on the LCD work. I click the kill button - nothing. I click the wheel - nothing. I spin the wheel - nothing. The display does show when the SD card is inserted and removed - but that is all I can do with the LCD at this point.

I have tried switching the LCD cables around - when I reverse them it goes blank, so I know i’ve got them hooked up correctly. (I also powered down before switching cables around).

I have attached the log file from the click_wheel error mentioned above - though I don’t know if it will be of any value seeing how I got it to compile by updating the u8glib in Arduino.

compile-error.txt (384 KB)

Not sure if a problem I had with my LCD might be related, but check the last post of the following thread for details. If you got the display from Ryan’s shop here on the website, this probably isn’t it because he checks out all his stuff before it ships.




I did buy everything from Ryan. I pulled the LCD off, and didn’t see any bridging on the knob solder joints.

I did, however, notice that all of the solder joints on the bottom of the circuit board (the half with the speaker, knob, and kill switch) were all dull (cold solder joints maybe)? There was also some kind of film or something (like it sat in salt water or something).

The rambo appears to be working with pronterface. I can move the gantry and home it (i have to hit home twice though - it seems to stop in the middle). I’m hoping its a setting I can change when I get the LCD working.

[update 3/31/18]

After visiting with Ryan, I touched up the solder joints on my board that were dull. Everything is working now. Thanks Ryan for your help.

[original reply]

I fixed the issue with homing by setting the bed size to the footprint of my machine - and re-compiling.

Still no luck with the LCD. Hopefully Ryan has some suggestions for me.

I hit this issue as well, with an LCD bought from V1 engineering. Hit this thread trying to find a solution. I also notice that the solder joints near the dial appear darker/duller than most others on the board. I’m using the stock firmware from a Rambo board that I got from here, along with the adapter.

I’ve swapped the cables…I get a blank screen and a ‘click’ if I do that.

I tried running a knife between the solder joints in case they were fused, but they look split to me. The screen powers up, and responds when the machine moves. Clicking the dial causes it to go to the menu. Rotating it does nothing. Another click sends it back to the info screen.

I’m hoping it’s not bad, I’d just gotten it plugged in and was excited to start printing from SD

Attaching files showing bottom full vs shiny solders, and top…I see what may be the problem, looks like a solder blob

Can you solder/fix the blob and it should work. If not ship it back and we’ll do a swap.

1 Like

Got it working! Hot iron and a desoldering braid for 30 mins did the trick. Just kept pulling excess out. I think a solder sucker (or more skill) would’ve made it faster. Sadly I had neither but glad it’s working now :slight_smile:

Awesome, thanks for trying…and succeeding!