Some general help needed

I set my MPCNC axis’s to where I want them to be zero using he LCD unit, then I reset the rambo board and all my axis show zero on the LCD unit. However sometimes when I reset rambo the z axis tries to drive down through my table. Also after I run a program the z axis tries to do the same thing even though the end of my g code has the z axis going to +10 mm.

Also is there a way to setup the auto home function on the LCD panel. When try to auto home all axis’s try to go past the physical limits.


Not without using the dual endstop firmware. “home” really means, Drive until you hit an endstop.

What software are you using to make your CAM? How are you telling it to go to +10 when it is done? Are you sure your axis is not just dropping from gravity when the steppers power off?

In estlcam there is an option to “finish above…”. That is what you should be using.

Same as above, maybe gravity, or is is specifically 10mm?