Spoil board allignment problems any help please

hi guys i got the mpcnc up and running but now got new problems with no idea on where or how to start and fix them , firstly is X axis 1 of the motors seems to be either to fast or slow as the motor at the back of the machine every now and then makes like a quick grinding sound as it springs into place to catch up and the second issue is in the pictures you can see where i have tried to make a spoil board out of mdf that the holes start to line up until it does the top 3 rows which are out of alignment on the first pass then the second pass all of them are out of alignment then the third pass if you look at picture 18 where it starts to do the holes for the threaded insert of the T-NUT they are also out of alignment even more so . iv tried the belt tension which sort of helped a bit but even when its square to start with as it moves on the x axis by the time it get half way along its out of square again . my measurements for the spoil board are 315mm on the Y with 7 inserts and 1085 on the X with 26 inserts on a 40 x 40 mm grid and the programming of this i think it was 1mm cutting depth per pass , iv checked all the wiring as was suggested in another group and all is ok there iv also included a picture of the settings i think i used . im using ESTLcam for to create the G-Code and Repertoire Host to operate the mpcnc itself as im using the RAMBO 1.4 board . iv done a test run of a 40 x 40 mm square with a cut out fora T-nut which worked fine with minor differences by approximately 1mm on the sides of the square which im hoping can be sorted out either after the spoil board is done or before depending on what kind of info i get in regards to this current problem i have . i have not wired up any end stops yet as i wanted to get the spoil board done the set the end stops up just inside of the spoil board where the cutting would begin on the a block or to be adjusted as necessary further in on the board


Here are a few things that come to mind that you can check.

  • Pulley grub screws. Make sure they are tight. Hopefully you assembled with Loctite or similar.

  • Set/check all your stepper driver’s current/Vref.

  • Swap drivers with the Y-axis to see if the problem moves. Make sure you power down first!

  • Remove your belts and confirm that both steppers are turning (and in the right direction).

  • While the belts are off move the gantry around to confirm that you don’t have any tight spots.

  • Make sure that you don’t have a cable that is getting tied up somewhere while the machine is moving.

I would hold off on cutting your spoil board until you get your motion right to minimize wasting material. Hopefully one of the above suggestions fixes the problem or someone with a better idea chimes in. Good luck!


Make sure your sides are equal to each other.

This is a good test for that as well as a tape measure.

This sound is non-destructive. It is caused by the stepper not being able to advance and then whipping back around. Whenever you hear this sound, you’ve lost steps, and your cutting will be inaccurate from that point forward. Lose grub screws on a pulley (a common problem we see on the forum) combined with positions where the axis does not move as freely is the closest match to your symptoms. @Bigchepin post is an excellent list of troubleshooting steps that will allow you to isolate the problem…or at least allow you to give us enough information to provide you with next steps.