Squaring with dual endstops

Hi everybody,

I am completely new to the MPCNC and this forum.
I have a finished working build and already did some nice cuts with it.

My problem is that it the cuts are not square ( was not important for the cuts I made so far )

So I checked the rails, and they are more or less square.
( I actually find it very hard to measure if it’s square, once the build is complete, any tips ? )

I have my end stops set at exactly the same distance from each corner.
The problem is, when I home the X and Y axes, on both axes, only one of the end stops gets triggered ?? So the gantry is obviously not square.

This brings up two questions for me:

  1. I tried tightening and loosening all the different bolts that should help to square everything, and yes, it makes a slight difference, but not enough. I mean, when I home the axes, one end stop gets triggered but the other one would need like 10mm more travel for it to be triggered. Could my printed parts be bad ? Any ideas ?

  2. I thought that the end stops would kind of “autosquare” everything by running each stepper ( X1 and X2 ) until both hit the end stop. But to me it seems that they both just stop when one of the end stops gets triggered !? So, I dont’t see how this could help with squaring ? I’ve read that maybe the end stops are swapped, so I tried to swap them, but same result. Also, I don’t understand how the board ( using Rambo 1.4a ) could even control only one stepper motor. When I look at the wiring diagram of the two steppers on one axes, I don’t think the board can control only one motor, right ?
    ( yes, I checked the end stops using the M119 command, they trigger correctly )

Also, in some posts I’ve read that it is important to wire the steppers correctly, meaning it seems important which stepper is X1 and which one is X2. If that is so ( even though I did not see this in the documentation ), how to tell which one is which ?

I also wonder if my steppers are even all running ? I mean, how could I even tell if X1 is running, but X2 isn’t ? ( it would still move the gantry, right ? )

I hope that a was clear enough, because english is not my first language, and all these technical terms are rather new to me.


It sounds like you have it wired wrong. The X2 and Y2 should go to E0 and E1 motor ports.


You need the dual firmware to get E0 and E1 to run. You can get it at MarlinBuilder releases. You can send M115 and it will show a version number, like v513D. If it is D, then it is configured for dual drivers/dual endstops

1 Like

OMG, how did I miss that !

So, basically, when using dual end stops ( version IS 513D ), the steppers get wired individually, not using the “spicling” cable.

I will have to re-wire everything as I used custom made cables. grrr …

Thank you !

Oh, bummer.

If you want to use it for a while first, you can make some “hard stops” to pull the gantry against to make it square while you enable the motors. They will move in lock step after that.

1 Like

Oh, yes, I see what you mean … but no :smiley: !
I want it to be “perfect”.

Thank you so much !