Starting cut plunges down -3.00

Hi everyone,

I am just posting a quick question here since I am not sure what’s happening. I tried cutting some aluminum today on my mpcnc and I broke 3 1/8" bits one after another. I didn’t know what was happening until I checked to see how deep the cut was and where the bit broke. I noticed that on my panel I would see -3.00 when the cut started, I decide to zero Z about 15mm above the starting point to be sure.

Once the print started I saw on the panel that it would go down to -3.00 even though I am telling it to only go down 0.10 - 0.50 its not doing that. Can anyone give me a suggestion on where to look to see why its doing this?

When I was cutting into mdf everything worked fine as that material is soft, whether it was going too deep or not I didn’t even notice because I didn’t break any bits. But since moving to aluminum I was not that lucky.

I have my setting like this to test but it doesn’t make a difference.
Screenshot 2021-11-07 210335

I played with the depth per pass down to 0.40, 0.30, 0.10 but it still plunges straight down 3mm.

Any ideas?

I’m only an occasional EstlCAM user, but when problems like this show up on the forum, usually it because the Basic Settings are setup something like this:

Or possibly you have CNC program start set to “Above origin.”

So the clearance plane is 3.00 mm above the stock, and the CNC program start is set to the clearance plane. That is, EstlCAM thinks it is starting 3mm above the stock, so it moves down 3mm to start cutting. If this is the case, change CNC program start to “At Origin.”

1 Like

What do you have that set to?

The clearance plane is the setting where it will pull the tool for rapid moves.

Also, are you setting Z=0 to be the top of the material.

Make sure that you are setting Z=0 (Or setting your Starting depth) to the top of the material. Make sure that your clearance plane is above this height. (Or is above the top of the material, if y ou are setting Z=0 to be the machine spoilboard.)

1 Like

Thanks guys, I knew it had to be a setting but I wasn’t sure where to look and what to look for. When I get home I will check the settings to see what I have.

To answer the question, I do have my zero set to the top of the material and not the spoilboard. Once I set my Z to zero I move Z up about 2mm and then click print. My starting depth is always set to zero the default.

I will check and test when I get home and let you guys know.

Thanks again for the help, yo guys are awesome!

I just checked my settings on my laptop and this is what I have, it looks like everything here is set correctly. I think this is how I set everything up when I was following the guide on building the machine,

As next steps:

  • Check to see what (if any) start scripts you have in EstlCAM. See Setup/CNC Programs/Tests
  • Attach your g-code to a post so we can take a look.
  • Look at any start script in whatever you are using to send the g-code to the control board.

This is what I am seeing now. I know there was nothing with a ‘3’ in any of my settings so I started looking at my config to cut the material. I was under the assumption that the toolpath depth is how thick the material is. But once I changed that value to 1mm, then 0.8mm I noticed that when the job starts it goes to that number.

If I am using the program incorrectly then where do you tell the program that you only want to cut lets say 5mm out of a 10mm piece of stock.

All of my scripts are commented out in every area, I m glad you mentioned to look there as I was wondering why the spindle moved up 30mm after the job so I commented that out.

Here is a sample gcode that I was working with, it prints in mid air so I don’t break any more bits.

Slider-test.gcode (9.8 KB)

Toolpath depth is how deep you want to end up cutting a particular object (meaning cut operation, as in part/hole).

Other factors being considered, if you have a 10mm piece of material and want to cut a 5mm hole - your toolpath depth would be 5mm.

Further explanation video:

That is exactly what I thought when I set everything up according to the help tips that popup. I have re-flashed this rambo board because I thought something was corrupted in the eeprom. Nothing changed after that so it couldn’t be the firmware.

I really don’t know where to look anymore, maybe I just need to stick with wood cutting.

Here is the drawing I am working with in case anyone wants to take a look. (12.9 KB)

When you run that Slider-test.gcode file, are you saying it cuts down 3mm from the top of the material (which would be Z=0)?

That test file only cuts a total depth of .8mm and you should be able to “visually verify” that by previewing it in Estlcam as well as other free software such as Camotics.

What are you using to run the gcode file and communicate with your MPCNC - SD card, Repetier-Host for example?

Exactly, I had 3mm as my DOC and Z would plunge down 3mm into the stock and break the bit. The only place that I had a 3 was in the DOC. So I did a test to see if that had anything to do with it, once I changed the value to 1mm then Z went down 1mm when the cut started. I then changed it to 0.8 and Z moved down 0.8mm from the zero position. I am using Repetier-Host.

OK, then based off the gcode you shared, the issue is a setting or step in Estlcam.

If you performed a single operation using settings similar to this (the two fields highlighted with yellow are key):

Then your gcode should be similar to this (note the Z-0.5 and Z-0.8):

;Project Slider
;Created by Estlcam version 11 build 11.242
;Machining time about 00:09:40 hours

G00 X0.0000 Y0.0000 Z0.0000 F2100
G00 Z4.0000 F480

;No. 1: Hole 1
G00 X11.0526 Y12.1909 F2100
G00 Z0.5000 F480
G01 Z0.0000 F60 S24000
G01 Z-0.5000 F60
G03 X15.4066 Y14.7046 I1.4513 J2.5138 F6
G03 X11.0526 Y17.2184 I-2.9027 J0.0000 F6
G03 Y12.1909 I1.4513 J-2.5138 F6
G01 Z-0.8000 F60
G03 X15.4066 Y14.7046 I1.4513 J2.5138 F6
G03 X11.0526 Y17.2184 I-2.9027 J0.0000 F6
G03 Y12.1909 I1.4513 J-2.5138 F6
G00 Z4.0000 F480
G00 X0.0000 Y0.0000 F2100

I have to agree with your findings. I just did a few tests and this is my experience.

  1. I set the hole parameter to cut 7mm along with a DOC of .8mm and then tried to save as gcode, I was then prompted for a cutting depth even though I already put in the cutting depth.

  2. I looked at the gcode like you said and I could see that the tool settings that I assigned to the cut is not the one being utilized in the cut. I tried deleting the first tool on the list since it was pulling those values and it would not allow me to delete, it said something about the tool being used in the cut. I closed the program and once re-opened I deleted the first tool on the list. It seems like its still not taking the settings from the tool that I select since its still asking me what depth that I wanted when saving the gcode.

It seems that I have found my problem, once you pointed out those areas in the code where I should have those two values and they were not there, it looks like this is my issue. A new update to the EstlCam software was just released and I installed but that didn’t make a difference.

I don’t want to waste my time emailing the author because I have emailed him asking a couple questions weeks ago and have not received any responses.

Are there any other software packages that’s compatible with the hardware that we are using? Rambo board and Marlin.


If it is prompting you for a cutting depth are you sure that you are assigning the tool and cutting depth to the feature you are trying to cut?

Edit: Even if it is asking you for the depth of cut - enter in the same value you want and then save it/look at the gcode. What are the results?

Once it asks for the cutting depth and I put it in manually the gcode then reflects what I put in. I was checking to see what program the guys in the Sketchup forum uses to post their tiny videos so I can make one and you can see. I am testing this at work and I am seeing the same issue. Maybe I need to uninstall/reinstall.

I uninstalled the program, deleted all the settings left behind and re-installed. Its not prompting for the depth anymore and the gcode looks good. All that’s left is to test when I get home.

1 Like

Great, glad you stuck it out and we could figure that part out!

1 Like

I would really like to thank all of you folks for helping me out.

1 Like