Starting to get frustrated

I’m trying to upate the firmware on my SKR v1.3. I am using the Teaching Tech firmware with some changes. First time I compiled it with no problem. Now, after adding probing and changing the homing direction I keep getting the following error.

PLATFORM: NXP Arduino LPC176x 0.0.2 > NXP LPC1768
HARDWARE: LPC1768 100MHz, 31.80KB RAM, 464KB Flash
DEBUG: Current (cmsis-dap) On-board (cmsis-dap) External (blackmagic, jlink)
PACKAGES: toolchain-gccarmnoneeabi 1.90201.191206 (9.2.1), framework-arduino-lpc176x 0.1.3
Converting Marlin.ino
LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ off, Compatibility ~ strict
Found 5 compatible libraries
Scanning dependencies…
Dependency Graph
|-- 1.0.0
|-- 1.0.0
|-- 0.4
|-- 0.6.2
|-- 1.2.4
Building in release mode
File “C:\Users\Ryan James\Documents\3D Print Files\CNC\LowRider2_CNC\mpcnc lowrider 2 - marlin 2.0 and mks tft firmware\marlin 2.0 - mpcnc lowrider2 - skr v1.3 tmc5160\Marlin\src\HAL\HAL_LPC1768\upload_extra_script.py”, line 16

print 'Unable to find destination disk (' + e + ')\n' \

      ^

SyntaxError: invalid syntax

===================================================================================== [FAILED] Took 2.54 seconds =====================================================================================

I’ve verified that I am using Python 2 (because apparently Python 3 isn’t always support)(and I get the same error either way). This happens every time. Not sure what to even look at anymore.

-Ryan J.

There are a few ways this board can be configured and a bunch of people using them, I hate to say this but if you search SKR I bet there are a few links of precompiled firmware for your config or pretty close.

On the other hand If you want some help here you should probably list your drivers, how they are connected, and what LCD you are using.

Another common problem is the sd card they come with is often not good and needs to be replaced. I have never tried to flash mine so that is as much help as I can offer.

Have you tried platform.io, I believe it is fully configured for these boards now.

Yeah. This is ringing bells where another user had this same error message (“Unable to find destination disk”). IIRC, it was something in the tt firmware.

Hey Ryan , I have the same exact problem and makes me wonder what we are doing wrong .

mine started with the ‘Default_envs’ thing that had to be change and now the print thing the last to clear.

The thing is that I originally used TeachingTech’s firmware and had no problem. It wasn’t until this last set of changes that the problem started. I’m trying to remember if I got my new laptop before or after the first compile but I’m certain it was before so the software versions haven’t changed.

I’m going to start with a fresh TT file. If that doesn’t work I’ll have to either go from scratch (not looking forward to that but would be a good learning experience) or modify the V1 firmware.

TT did not work. V1 MPCNC Dual Endstop did not work. Both gave the same error.
Basic Marlin 2.0 is compiling. Now to figure out how to fix the dual stepper for Y and Z and everything else…

Does the default Marlin have the same stuff in the platform file? That’s where I would start looking. I am wondering if one of the tools in pio changed. That is not the normal kind of code error. Marlin is written in C and that is a python error. So it is something in the tool.

I am also not sure why it cares at all about the destination.

The default Marlin Platformio.ini is different. I’m adding parts one line at a time to see when it fails.

It’s not that it’s looking for a drive, it’s that it is having an error with the print syntax for some reason in that one script.

do you all running now ?

There is only one single line in there that gets edited. You just need to tell it what board you have.

default_envs = rambo, Swap Rambo with whatever the old file had. As for the rest I am not sure what version you are using or what your end goal is. If you have one that is working, are you just trying to learn about the firmware or trying to get a new feature? Firmware is a finicky thing. If you have a working build there is not usually all that much reason to update.

Ryan can you post a pic of here this is ? This is my first time usting Platform.io please it will be of great help .Thanks

thanks- so I am using the download file from TT .I saved it on my desktop and installed the Atom /platform, them I got the open folder and and opened the unzip file. After I went in and did all the necessary changes because I am using the TMC 2130 and also change the defaults_envs ,then after I try to compile I get the error below even with the original files from TT with not change to the TMC5160 .

Error 1
Can not remove temporary directory C:\Users\Mary\Desktop\marlin 2.0 - mpcnc lowrider2 - skr v1.3 tmc5160\.pioenvs. Please remove it manually to avoid build issues

Processing LPC1768 (platform: https://github.com/p3p/pio-nxplpc-arduino-lpc176x/archive/master.zip; framework: arduino; board: nxp_lpc1768)


Verbose mode can be enabled via -v, --verbose option

CONFIGURATION: https://docs.platformio.org/page/boards/nxplpc-arduino-lpc176x/nxp_lpc1768.html

PLATFORM: NXP Arduino LPC176x 0.1.0 > NXP LPC1768

HARDWARE: LPC1768 100MHz, 31.97KB RAM, 464KB Flash

DEBUG: Current (cmsis-dap) On-board (cmsis-dap) External (blackmagic, jlink)

Error 2
File “C:\Users\Mary\Desktop\marlin 2.0 - mpcnc lowrider2 - skr v1.3 tmc5160\Marlin\src\HAL\HAL_LPC1768\upload_extra_script.py”, line 16
print ‘\nUnable to find destination disk (’ + e + ‘)\n’ \

From what I understand Atom is not supported.

Ok , so what software combination do I need to compile and load this file to avoid all this frustration since I am just changing me to TMC 2130 instead of the 5160 . Sorry but I am very new this and thanks for the your time and patience .

I use vscode and platform.io…but like I said I have zero experience with that board and all it’s intricacies.

That is actually a lot of changes, one of the reasons I do not care to use those drivers.

That took care of the syntax error but introduced a whole slew of other ones. I’m going to work off a fresh Marlin config and see what I can get to work. My only problem is going to be configuring for the dual endstops…although I’m considering just going without and only using a z probe.

This is the error i get with Ms Code

{
“resource”: “/c:/Users/Mary/Desktop/marlin 2.0 - mpcnc lowrider2 - skr v1.3 tmc5160/Marlin/Configuration.h”,
“owner”: “C/C++”,
“code”: “1696”,
“severity”: 8,
“message”: “#include errors detected. Please update your includePath. Squiggles are disabled for this translation unit (C:\Users\Mary\Desktop\marlin 2.0 - mpcnc lowrider2 - skr v1.3 tmc5160\Marlin\src\core\serial.cpp).”,
“source”: “C/C++”,
“startLineNumber”: 2,
“startColumn”: 1,
“endLineNumber”: 2,
“endColumn”: 30
}