Steeper motors dont manually work in repetier

Hi All,
I’ve got the Marlin firmware all installed on the Arduino complete with 100K resistor, I’ve wired the 5V and 12V power to the 4 ‘Green’ connectors. When I go into repetier it recognises the board but the manual movement of the motors does not work, I’m convinced its power somewhere, anyone any ideas … Many Thanks

It should be 12v in both sides of that plug

Thanks for the reply and I’ve now put 12V into both plugs. Repitier now starts to run the motor but the Nema 17 just whines and does nothing, the shaft of the motor is tight though when running but the motor doesn’t spin. Below is the model of motor I have:

Manufacturer Part Number 17HS19-2004S1
Step Angle 1.8°
Step Accuracy 5%
Holding Torque 59Ncm(
Rated Current/phase 2.0A
Phase Resistance 1.4ohms
Voltage 2.8V
Inductance 3.0mH±20%(1KHz)
Weight 400g

I know the voltage is 2.8V but I can’t get a 12V one rated at 2A, The link in the assembly section to the Nemas on Amazon show the same as above but do not display the voltage. Have I simply purchased the wrong motor. Thanks

what drivers are you using?

your steppers are 2.8v*2A= 5.6W so 5.6w/12v=.467A per motor needed.

use that figure to set your drivers. You are either over or under powering them. Make sure to do all this testing with no belts attached.

UPDATE: Tried a different motor and get the same as above. High pitch whine, motor shaft wont turn. Thanks

Hi , Thanks for the reply, much appreciated. I’m using the 8825 drivers, RAMPS 1.4 with Marlin installed. Checked the drivers are facing the right way (Pots toward power) and I have the 3 jumpers installed too.

set the X and y Drivers to 0.7V and the z to 0.42v That should be fine. Are you using my firmware? if not did you calibrate the steps per mm?

I’m not using your firmware, I got the Marlin software from the site and no I didn’t calibrate the steps per minute. Apologies for the basic questions but I hope they can help someone else:

Do I have to buy the firmware from you (have to ask :slight_smile:
How do I calibrate the steps per minute, point me to a link would be great.
and do I set the drivers per the video on the site (Setting the current limit…)

Many Thanks, I do appreciate it, printed all the parts and they fit perfect, slides along nicely. Very impressed.

My firmware is pre-configured marlin. You should only be flashing mine. Your issue is stepps per mm, reflash my firmware if you are using 16t pulleys and you should be up and running.

video on setting the drivers in here,

Last question for you please, where / how do I get your Marlin firmware. Thanks. linked at the very bottom, use the beta

Thanks again for the reply, I flashed the RAMPS with your firmware, I changed the baud rate and that’s all really. I still get the same on both motors, weird. The only thing left is the steps per minute so I’ll go ahead and change that somewhere. I’ve changed the stepper driver just to be sure but still no dice I’m afraid.

Why did you change the buad rate? Did you change it in the software, firmware, or both?

If you are on a pc, don’t mess with the baud rate.

The steps are pre configures in the firmware that is not the issue if you are using 16t pulleys.

Thanks for all the info so far. Learning. I managed to install a script that test the steppers through RAMPS and runs a few LED’s on the RAMSP board, all went well, the motor moved clockwise then anti-clockwise nice an smooth. So I guess from this testing it must be Repetier that needs to configured somewhere for the steppers. Thanks

Areyou using a Mac or no?

if you are the firmware and repetier need matching buad rates, thats it, maybe a different driver.
PC - plug and play firmware and repetier already match