Stepper gone mad (Video) - Is this a driver, the ramps board, or the arduino?

This video (Google Photos) shows some crazy stepper behavior I rooted out when working on my troublesome Z axis. The axis had been jamming, worked on it, new allthread, drilled out, loosened the 5" bolt (This is the 525 machine on american conduit) and shortened the Z length. The stepper acted weird, changed drivers, same behavior. I could turn it by hand, there was some resistance, but the problems continued after I loosened it up.

So, I thought “More power, why not…” and replaced the 64 oz/in with an 84 oz/in and set the vRef to 0.88 for the 2 amp stepper. Then the behavior shown in the video really came out. The 64 had been weirding out, spinning backwards and forwards on the same move, but not as dramatically… Holding torque on the 84oz is noticeably more impressive, BTW.

So, I hope someone is going to say “Had this, reflash the firmware…” before I buy a new RAMPS set…

I guess I’ll work on my laser in between. That’ll be fun!

Thanks in advance, all.


Oh yeah, Firmware for 16T pulleys, latest, I think. This is all material I bought for my previous build that had worked great.

If you swapped the drivers and the actual stepper the only other thing would be a loose connection. Faulty wire

sounds like when I had my stepping wrong when I first started as well guess it gets bunged up with the code being sent it has a issue computing if you just send one line at a time does it do what its suppose to? if it does then settings are off.

Thanks for the Thanksgiving morning help, Ryan! I ran out and resoldered a new connector to the RAMPS end of my (Brand new 18 gauge shielded) cable, and that fixed the stuttering and random direction changes, but I still can’t get the motor to advance much. (Video - Google Photos)

If you can hear it in the beginning of the video, the stepper and driver are ticking like a metronome, about once per second, which is new to me. It started doing that again about three seconds after I tried the last Z move.

X and Y axis are moving fine, and I feel no resistance on the shaft (No load). I put a brand-new out of the package driver on it, and tried Vrefs from 0.6V to 0.88V with no change. For more info, I plugged it into the working X-Axis spot, tuned the Vref, and got the same result… Could my Z-axis cable be too long? (It’s around 12 feet long). Could a bad driver have ruined my stepper that fast? I have one more motor left, but I’m scared to hook it up…

Also: The guide to the stepper I switched in gave the pairs as being different than the connector was wired. I tested with a multimeter and found the connector went “A1 B1 A2 B2” instead of what I expected at the connector (A1 A2 B1 B2). So I wired it as to what I found in the docs and multimeter. Did I screw that up, maybe?

Ignore me and enjoy your thanksgiving, and thanks for your help when it’s convenient for you!
I’m going to try that last stepper (on the X axis) as it was shipped and wired and see what happens.


what values are on your z movement?

Hi Wesley, I’d been trying accels under 40mm/S^2, and feeds of 400mm/min to 200 mm/min, as in G1 Z30 F200, as well as repetier commands.

Big update, I screwed up the wiring! Used some M-F dupont wires to swap it back, and apparently I should have left well enough alone! Now it’s time to slap it into the center and get dusty! Thanks again, helpful friends!

Enjoy your feasts!


awesome and I am in Canada its a coffee feast this morning lol

I assume you fixed this but I had the exact same problem happen to a known good setup with my 3d printer. It was a poor connection at the motor connector.