Stepper Motor Issue

I have not used my MPCNC for around a week, I have come yo use it today, turned it all on and started to use repeatier to move the axis, my Y axis wasn’t working but z and x were, I realised that my cable had come unplugged from the Y where it joins in the tubes, plugged this back in all X and Y moved as normal, Z suddenly stopped and when I tried to send it up it started making a noise like it was binding, it normal doesn’t move and seems to shake when I attempt to move it up or down, not sure how this happened. I never had to touch the connections on the board as I had already realised the loose connection for the Y wasn’t at the board. Is this just a faulty stepper motor or is it something more serious, I have reset the board, unplugged it and left it a while but still the same issue. If it is just a faulty stepper I will order a new, just after some advice on this situation as I bought all the kit from Ryan apps 6 months ago so not sure if it is just the stepper motor as they aren’t that old or been seriously worked.

63b840a3-4fca-4c6b-99e4-e3e164a83834.mp4 (1.67 MB)

I would try to isolate the problem.


Disconnect the stepper motor from the assembly and see if it moves smoothly. If it does, the assembly is causing the issue. If not then it’s somewhere between the stepper and the board.

Also try to swap out the z motor with an x or y motor and try again. If it’s still behaves the same then it’s somewhere between the board and whatever wiring you have that’s consistent with the z.

If you completely test an entire new wire run and stepper motor and still behaves the same, then it’s likely the board or code that needs attention.


It was a wire issue, back up and running now.

1 Like