Stepper Motor lock, and high pitched noise


I just finished the build of my dual endstop mpcnc and tried to get it working. I began by plugging in all the steppers and it work however only the x1 and y1 steppers were activated. So i downloaded the latest MPCNC_Archim1_T8_16T_LCD_DualEndstop files from github and uploaded them on to my archim v1. However when i restarted the mpcnc and tried to move each axis the steppers would lock-up and a pitched noise would arise.

I tried to upload another firmware with 16 steps instead but the same issue appeared. I would appreciate, any help.

Board: Archim v1, from this site
Firmware: MPCNC_archim1_T8_16T_LCD_DualEndstop
Power supply: 12V 5A:

Steppers: nema 17 59Ncm 2A 1.8 4-lead 48mm stepper motors.

Could the issue occur due to the 5A on the power supply? Not sure of this since i was able to use the steppers before.

Thanks for any help.


Are you homing first?

Yes, i have tried to home the motors first. But they still lock-up and them im unable to move them until i remove the power.

I have attached pictures of the setup. For now i have only connected the X and Y steppers and their endstops.

You are using unknown (to me) steppers, you need to verify how they are wired by checking for pairs. The pairs on the board are 11AA, your stepper plugs could be anything.


1 Like

I had the same issue when I accidentally had my steps per mm set way too high in the firmware.

1 Like

I have now cheaced the pairs and i now sure that i wired them correctly. Im am now try to change the steps from 32 to 16 but im not quite sure if i have done this correctly. The changes that i have done to the firmware is the following:

#define DEFAULT_AXIS_STEPS_PER_UNIT { 100, 100, 400, 100 }


// Microstep setting (Only functional when stepper driver microstep pins are connected to MCU.
#define MICROSTEP_MODES { 16, 16, 16, 16, 16, 16 } // [1,2,4,8,16]

You are right there is something odd with the firmware, I am working on it now.


No reason to change to 16th stepping on a 32bit board.

1 Like

Hi, im still have in trouble with the steppers.

I have been trying different combinations of the stepper wires. I found the pairs and connected them according to the picture, where black and green is one pair and blue and red is the other pair.
Next i tried to se if all the endstops where correct and i have connected them so that when i run the M119 command they all so open, but when i push them down they show triggered.

I have only connected the four stepper for the X and Y axis do i need to connect the Z axis aswell and do i need a fith endstop for the axis?

Im still having issues with the steppers locking once i try to move them.

Have i connected them wrong or could the issue lay within the firmware?

Any advice is appreciated, thanks

Are you running the dual endstop firmware or the regular firmware?

Im running the MPCNC_Archim1_T8_16T_LCD_DualEndstop firmware which i got from github.

Use the links on the firmware page for the archim directly next to the github page as noted on the firmware page.

Using GitHub

You will find this on the V1 Engineering Marlin GitHub page. Use this link for Archim (series) or Archim (Dual) boards (for now).
1 Like

Thanks ill give this a try and hopefully get down to milling, can’t wait for the first cuts.