Stepper Motors Stalling

Hey again,

I’m having reasonable success with the Lowrider, got a couple of projects I’m hoping to get cleaned up to post here, but I’ve been running into a few problems while trying to cut some pieces for this bed;


I’m cutting at 600mm p/m, any slower and my router gets a bit too hot, with a 6.4mm two flute straight bit at a depth of 4mm. It’s 18mm ply, but I’m under the impression this shouldn’t be pushing the machine too hard.


I’ve had issues with USB Cable interference with previous CNCs so on the Lowrider I’m only running it off the SD card, so I dont think it would be an interference issue, unless its 230v interference along the X axis stepper motor? That said, I have them spaced as far as possible apart and the stepper is wired in stranded cat6e

I’ve found that either of my Z steppers sometimes suddenly stop holding, generally one at a time. It can be while cutting, can be while setting the origin.

I’ve also had issues with my X axis binding up, today it was while cutting this attached area.


Stepper motor current is set to;


X axis - .80v

Y axis - .78v

Z axis - .82v

I’m wondering if my power supply isn’t quite beefy enough, the steppers are 1.7A each, with the supply only being 3A - Initially I assumed that the 1.7A rating would only be a stall current, but now I’ve typed that, I’m thinking that could very much be the problem…

Any other ideas?

Assuming it is the power supply, what kind of supply are you guys running? I’m figuring it’s going to be 5.1A-6A?


Should I be running 12v or 24v?

Same power supply, wired in series, 12V 6A exact same stuff I use / sell for both machines, 16T pulleys.

Make sure your bottom wheels are not pinching too hard, and your speeds are reasonable 8-15 mm/s. You can adjust the router RPM to suit it.

Weird, I can’t seem to find my original post.

I’ve just changed over to the 12v 20A supply that came with my 3d printer, it’s better, but still not cutting how I would like. I’m thinking now it might be that the bit is no good.


The bit is a two flute straight 6.4mm and depth of cut 4mm @ 11 mm/s

Nope, still the same issue. I’ve put a fan on the stepper drivers, upped the vref to .85v, oddly enough the X axis is now running a bit cooler, my laser thermometer says the heatsinks are running at 25-30C, before it was around 50C.

It’s losing seizing up at the same place each time, when it goes up the X axis, this cutting path has less material than the path it ends up continuing with.

My Y axis wheels are actually a bit loose, so I don’t think it’s an issue with tightness. X axis moves freely when the steppers are disabled.

I have noticed I have a bit of give in the steel bars, one will move up a little and the other down a little, I’m guessing this is just a result of the design?

It wouldn’t be acceleration? If I recall correctly the firmware sets limits on that.

Maybe it is the bit…

I think I have solved it.

Purchased a new bit and it cuts much better.

Success with a 6.35mm two flute straight cut bit at depth of 4.5mm @ 15mm/s - Could be 5mm, but I run the layer heights at even stepdown.

Had to up the spindle speed to around 28,000rpm/80% (or there abouts, it’s a 33,000rpm router on a dimmer switch) which I thought could be a bit high, but the chip seems okay and no burning/smoking. I’m thinking it could have been to do with the speed control of the router, the dimmer probably kills the torque alongside speed.

It’s furniture grade poplar ply, so I think that could have been part of the difficulty, as the grain in the layers alternate directions.

I also put a fan on the drivers and upped the vref to .9-1v

Replying in case someone else runs into a similar issue.

Straight flutes? I have zero success with them but sell a ton. I use either upcut of downcut and it works much better.


Your topic ended up in the spam folder somehow, I restored it.