Stepper wiring for archim

I an have a problem with my Z axis on my LR2, I think it is in the control board because it works fine if I swap the Z and Y cables.
When I do a manual move it stutters and only goes in the down direction. Like I said I swapped wires and it works fine so I know the motors are good.
I am using the archim 1.0a board, ordered from V1 and so it cam preloaded with correct SW. the archim board has two slots designated for the Z axis, I received a “Y” cable to join them together, and plugged them into one slot. Do I need to get an extension cable instead, and plug them into each slot independently?
Any help would be great!

Usually a speed thing on the Z axis, other axis only move one direction when you are using dual endstops until you home. Another common issue is no lube on the screw or just out of alignment. Did you leave the nut a bit loose? I doubt it has anything to do with the board.

No, the harness gets you series wired, the board is parallel.

When you boot up what firmware is on the board? How are you making a manual move?

FW, I am using the LCD. The lead screws are lubed. I will loosen the nuts and try again… still not moving smooth. I can hear a hissing sound coming from both motors.

Did you make it yourself or you using mine? Mine should be followed by a 421-425

Ordered it all from you.image

Also took a video, hopefully you can hear it. I guess I can’t up load a video.
I disconnected the Leed screws completely and it still does it.

Hissing is normal. You do not need power in “A” best not to use it to prevent extra voltage running around your board.

How are you trying to move the axis from the LCD or reptier?

Try running my crown gcode see if that makes it work, or straight from reptier. For testing I would unplug the endstops as well since you are not running dual endstop firmware.

I am using the LCD to test the movements. I have removed the power to “A” . I would like to have a heated bed at some point. I do have a 3D printer head I am planning on trying as well.
I have disconnected the end stop cables, even though they were not connected to the micro switches.
Tried it again and still the stuttering sound is still there.

Okay please try from repetier, disconnect the lead screw just use a naked motor. if that does not work try a different naked motor. If that doesn’t work you should reflash the firmware using arduino.

Did you try this?

Tried the crown Goode test and that did not work,

I tried plugging in the X motor into the Z slot and it did the same chattering thing, using the LCD controller. I plugged the Z motors into the X slot and did the same test and it works fine. could the board be bad some how? I’m still looking into using the Repetier program and the USB cable. ( this is all new to me so it’s a steep learning curve for me.)

I have it up and running through the Repetier program. I got an echo:Unknown command: “M80”
echo: Unknown command: “M221 S100”
echo: Debug: Info, Errors.
and in manual control I still get the chattering with the Z motors, and also the Y are doing it to.

Try typing this in the manual commands tab.

G1 Y20 F400

then try

G1 Z20 F200


That will tell us what firmware is on the board.

OK I mentioned that I am new to this Code-ing stuff, how and where do I type in that info?
Am i supposed to be in the Repetier program or the Arduino?

Sounds like I need to add a page to the docs…

Commands go in the Yellow highlighted box, the green area will show the results (and usually there will be some movement).

1 Like

OK, thank you for being patient with me. I put in the code and the machine did move, but in the Z it just chatters. with the M115 command there was a long list of info displayed. first is the Firmware_ Name:Marlin 426
I really think there is something either wrong with the board or it could be in the commands. when I plug the cable for the Z into the X slot and do the movement test with the LCD, the motors move smoothly.

Do not use the wiring harness or extenders. Please plug the steppers in directly.

ok I plugged the motor directly into the board, and did the move test and got the same chattering.

Please try more than one.

I am not ignoring this, this is just the last thing it could be. I am not sure I have had more than one actual bad board from ultimachine in all of them I have ever sold. I am not sure what could be going on.

Can you also please upload a picture of your board all wired up please.