Steppers Do Not Move (but vibrate/make noise)

Assembled my electronics today to see if everything arrived in working order and have ran into trouble. I was able to download and flash the firmware. I didn’t change anything in the firmware code, just verified and uploaded it.

When I try to move the steppers with the LCD or with Pronterface they just vibrate/make noise, but the shaft doesn’t turn. When the steppers are disabled the shafts will turn freely.

Board: Ramps 1.6 & Mega 2560 Stack

Firmware: Marlin-MPCNC_Ramps_T8_16T_LCD_32step_DualEndstop


Drivers: DRV8825 (I tuned voltage pots to 0.75V)

Power Supply: Kastar (

Output of M115
FIRMWARE_NAME:Marlin bugfix-2.0.x (Github) SOURCE_CODE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:V1 E CNC EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff

Output of M119
Reporting endstop status
z_min: open

Did you add the jumpers under the drivers?

1 Like

Yes, three jumpers under all five drivers.

G01 X30 F400


Try that what happens?

1 Like

X Steppers vibrate/make pulsing noise for about 3 seconds. Afterwards LCD display shows X position as 30.

Figured out why your endstops say triggered, are they not connected? Are those weird heatsinks shorting out your drivers?

1 Like

I don’t have the endstops connected as I’m just testing, is this an issue? If so, how do I test without endstops?

I shut it off, took of heatsinks and retried and got same result.

Yes you need the endstops when using dual endstop firmware. Wired NC, you can short them if you know what you are doing, or edit the firmware but I suggest you just do it correctly an plug them in.

1 Like

I hooked one of the steppes up to my 3d printer extruder and it worked fine, so it would appear that it is not an issue with the steppers.

Ok, I’ll wire up the endstops and report back.

Ok, I jumpered the X and Y endstops and reran M119 to confirm.

Reporting endstop status
x_min: open
x2_min: open
y_min: open
y2_min: open
z_min: open


Stepper behavior did not change, still just vibrate and make a pulsing sound.

Steppers have to be wired normally closed.

How do I wire the steppers differently?

I think Barry meant End Stops need to be NC.


I’ve tried the endstops both open and closed. When they’re open it shows is triggered, when they are closed they show as open. What am I missing?

Okay, if it says open, then it’s correct. If you manually push one of the stop buttons while issuing M119, that one should show triggered. If that’s the case and you’re still not getting movement, then it’s time to test your stepper wires. The growling already has me thinking this is the case anyway. One of the pins isn’t connected at one of the connectors.


I’ve reconfirmed that M119 is working correctly. When I remove a jumper it shows triggered, when I reinstall it then it shows closed. Still no movement on the steppers.


I’ve pulled out the extension cable I purchased from V1, and tried just the OEM cable. Still no movement on the steppers.


I pulled the OEM cables and checked continuity of each wire from one plug to the other for all five cables, all had good continuity. Reconnected everything and still no movement on the steppers.

Matt K. on facebook suggested checking the cables to ensure they have the inner wires cross over. I’ve confirmed that the blue and green wires cross over from one end to the other.

Okay, unplug one of the steppers. Get a piece of wire to jump two of the pins on the stepper cable and give the shaft a spin. If it spins freely move one end of the wire to another pin and try again. When it gets hard to spin, that’s a pair. It could be that the steppers just aren’t wired correctly on their cables. I don’t think the crossed center pins is right, but I don’t have that kind of stepper.


Ok, I got it fixed! The green and blue wires were not supposed to be crossed it turns out. I pulled these out of the plug, flipped them and plugged it all back in and it all works now! Thanks everyone for your help!

1 Like