Steppers not moving

I finished the mechanic parts 2 weeks ago. I had problem to install the Arduino software I went online i finished to install it. It looks like last can’t find the problem to install Repetier host sofware even less follow the basic walk through it can’t connect. If anybody has any idea how to resolve this issue and make my mpcnc machine moves it’Lloyd a big help. Thank you!

Did you buy the electronics from here? If not what do you have, exactly.

Mac or PC?

You did install repetier or no?

I did buy a bundle kit and I installed the repetier host and sever.

You may need to install a serial driver separately. Did you run the arduino software and see if the board showed up? Or if a serial port showed up?

Are you using Windows? Or a Mac? When you plug the arduino and ramps into the computer do you see lights on them or a sound on the computer?

Finally, please post a picture of your arduino and ramps plugged in…

I am using Window 10 when I plug-in the Arduino and ramps into the computer I see the lights on and no sound
I make some pictures on my tablet try to upload them to the attachment it doesn’t give me access

Did you install the arduino software and its accompanying drivers?

You should be using repetier host, Only use server if you need it later on. Only plug int The ramps stack with the usb cable, nothing else should be plugged in but the resistor on T0 for troubleshooting.

You have access to upload fills smaller than 3000kb, if you don’t know how to shrink them please try imgur or a similar site to attach pics.

I am having a similar issue as Jean was. I recently completed my build, the following is additional details in regards to my build:

  • Downloaded and installed both Repetier and the Arduino software
  • Working with an XP computer
  • Purchased the kit from this site

I have never worked with Arduino and am concerned the drivers are connecting as they should. What are some common things I could attempt to remediate this issue?

In advance, thanks!

Windows XP is pretty old at this point. I am willing to bet it is a driver issue.

I just tried all installing Arduino and Repetier on a Windows 7 computer, resulting in the same issue as with the XP. Any other thoughts? Again it looks like the drivers are updating correctly.

You should start a new thread and give the details on your setup, where you got them and what software, ect. If you can give it a try on a windows 10 machine.

You can also install one of the many freely distributable terminal emulators for XP and verify the driver is working. Set the baud rate to 250,000 bps. If you’re not allowed to set that high of speed then you’ll have to slow the Arduino down a bit to match the highest speed your system can do (possibly 115,200 bps). I’ve used Tiny Term in the past for this type of thing.