Strange movement

Thanks to reading many forum posts, my Crown is fine. I cut my own wasteboard, which took a long time but completed successfully, and made some successful test cuts in foam and wood. Yesterday, I attempted to cut out a fence. My first attempt went well, other than I had not placed enough tabs in ESTLCAM and decided I wanted a cut-out in the vertex of the angle.

[attachment file=109372]

I made changes to the DXF in FreeCAD and re-did the CAM in ESTLCAM. But when I ran the job, I noticed some jerky movements that would always occur in the same place.

[attachment file=109373]

In both cases, the tool would jerk past the cut so quickly it would shake the machine. You’ll also notice that at the top left the cut turned out to be wrong angle.

When I first put the MPCNC together I noticed a similar behavior on one particular program where the tool would just wander off for a while and then get right back to what it was supposed to be doing. It wasn’t a jerk–it was a wander, and it was repeatable. The job looked good in Fusion and an online gcode simulator. I just chalked it up to not understanding Fusion 360, which I was attempting to learn at the time.

I’m running firmware 402 on a MKS GEN-L V1.0 with DRV8825’s. (I think I was running the earlier firmware when I had the wander problem.)

Any thoughts? Could bad wiring cause this kind of behavior even when some jobs are good?


[attachment file=109374]

fence2.gcode (167 KB)

This is really strange. Your gcode looks good and I don’t think wiring can do this, and I don’t think a mechanical issue would be so repeatable or give you that straight line segment at a weird angle.

The only thing I can think is the firmware is doing something strange, perhaps if the G1 movements are clipped to non-negative coordinates but G02 and G03 are allowed to go negative? It sounds like a stretch, but the areas where there are problems are just slightly negative. Also, it looks like the holes are almost, but not quite centered on the bars. I’m guessing they are supposed to be centered, because why would they be slightly off on purpose? And then maybe the cuts along the X and Y axes (at slightly negative coordinates) are being pushed into nonnegative coordinates by the firmware. This is a long shot.

Try power cycling your machine with the tool to the left and in front of your workpiece (which will become your extreme limit if you have soft stops enabled in firmware). Your entire workpiece will be within the machine’s limits. Then jog to your workpiece and issue G92 X0 Y0 Z0 to set your workpiece coordinates. You should then be able to run your job and reach the slightly negative coordinates without any problems. If this works, then I think it means you have accidentally (or maybe intentionally) enabled soft endstops. Soft endstops are problematic unless you always always home, and even then the are risky because you can easily forget where the machine’s soft limits are, e.g. if you disable steppers and drag the tool to the workpiece, and then if you hit the limits you ruin your work.

Although this seems unlikely, this symptom is really strange and I can’t think of anything else.

In estl cam you have the option to disable G02 and G03, this solved the problem for me. I cant remember what the option is called.

Edit: it’s called: use arc commands g02/g03, and it’s under cnc program settings.

Thanks for the replies. I learned a lot by just Googling the information in your answers.

I’m using the dual endstop firmware, which has the soft endstops enabled. I disabled them with an “M211 S0,” ran the program, and the side jerk seems to have gone away.

Then I–here’s the embarrassing part–re-read Ryan’s instructions for the dual endstop firmware. He says:

  1. Have a work offset when using the dual endstop firmware (which I didn't do).
  2. Set the origin(?) with "G92 X0 Y0 Z0" if you don't need the dual endstop functions (which I didn't do).
I'll try cutting with this later and see if it also clears up the centering errors Jamie noticed.

Thanks again!

Just an update…

With “G92 X0 Y0 Z0” and no offset, I still get the unwanted movement.

“M211 S0” seemed to work though, so perhaps I’ll try a cut with that.


G92 X0 Y0 Z0 doesnt actually disable the soft endstops, it just allows you to set a zero point that is safely inside your working space, so when you go negative relative to your zero point you’re still within the machine limits.

For this to work you have to jog to your workpiece so the machine knows that it’s inside its limits. If you disable steppers and drag to the workpiece it will still think it’s at the edge of its working space, whether or not you do G92. I think this is not quite correct in Ryan’s documentation. The non-dual typical workflow can fail for this reason unless you do M211 like you are doing.


It cut perfectly. Thanks.


Hey @monl I have exactly the same issue. How you ended up? Do you send M112 each time? Need a robust solution to avoid unnecessary steps.


I haven’t gotten the chance to work on my MPCNC in a while, so this isn’t fresh in my mind. However, enclosed is my ESTLcam “Program Start” text as I last left it. I’m pretty sure this is how it was when I last had things working.

;Created by Estlcam version build
;Machining time about hours

;Z-Probe (no endstops)
M211 S0 ;Turn off endstops
G90 ;Absolute positioning
G92 X0 Y0 Z0 ;Set Current position to 0, all axes
G0 Z5 F500 ;Raise Z axis
M00 Install Z Probe
G28 Z ;Home Z
G92 Z0.016 ;Account for Z probe thickness
G00 Z5.0000 F500 ; Raise Z probe off off of surface
M00 Remove Z Probe
M00 Turn on Spindle

@monl thanks mate. I will give it a shot and let you know!