Taller LR3 build

All bets off on the toasted board. No telling what voltages its sending on the 5V/3.3V lines, so it could cook many things.

Your PSU as 12.27V shoukd be fine for a good board. Shame about the toasted driver.

For your questions:

  • yes, I have my SKR Pro powered up with no motors connected right now.

  • yes, mine is powered with the driver power and board power in parallel from the same supply.

  • I think the new board should be able to protect itself from damaged drivers. The smoked one should be discarded.

  • i dont think that the driver needs to be the same brand. The BTT ones are Chinese manufacture, too. They are the same driver, with the same polulo pin configuration, I think the local replacements will be fine. A heat sink may be a good idea, you’ll still be using it for the same duty cycle and current settings.


Good news - the new board didn’t burn!

So ATM I can do the following:

  • I can move the gantry around the table successfully
  • I can home X/Y axes
  • I can start some gcode and have the machine “mill” it in the air (didn’t attach the spindle yet)

What I am having problems with:

Homing Z axis seems to be working incorrectly. It is actually quite tricky: When I select “Home Z” on the TFT, both Z motors start moving up the gantry. When the 1st end stop is reached (doesn’t matter which one - left or right - whichever is closer), the corresponding motor stops, and the other motor keeps moving. I think this is expected. When the 2nd end stop is reached, the 2nd motor doesn’t stop … it keeps spinning and the gantry keeps hitting the top of the cutout in the YZ plate and dropping back a bit. So I end up with a clicking cycle which basically never ends until I reset.

Use M119 to verify the switches are working correctly.

Just did, it works as expected, I can also see the leds light up on the board. Z1 and Z2 endstops trigger E0 and E2 leds respectively.

It seems that sometimes homing Z works fine. It also seems that the same problem happens to Y axis every once in a while, but not often. Generally homing Z works 20% of the times and homing Y works 80-90% of the times. Very strange.

That must mean a loose connection, or the triggers have some interference? Watch them super close to see if something odd happens when it does not trigger.

I think it looks more like a firmware issue. When the motor doesn’t stop during homing, I can see the related endstop LED light up on the board. So the board knows the endstop is reached, but ignores it for some reason and keeps trying to move the stepper motor.

I also tried triggering the endstops manually while the gantry is somewhere midway through the Z axis. If I press both Z endstops at the same time, one Z motor stops and the other keeps moving, even thought both LEDs light up. If I trigger left side first, the left side will stop and the right side will keep moving. If I trigger right side first, the right side will stop and the left one will keep moving. As if the board is only able to register one endstop at a time.

Maybe I will try to recompile the firmware and update it. I need to set the correct bed size and Z distance anyway.

Firmware issue do not tend to be intermittent. It works or it doesn’t. Are you using my firmware?

That is not correct at all.

Please upload pictures of your board, and how you wired your endstops.

I’ll bet that the second stop isn’t triggering sometimes because of the angle.

  1. Try bending the switch arms a bit to make sure that they’re centered on the Z stop tabs.

  2. If you’re using metal XZ plates, I think Doug (design8studio) has made little stops for the metal plates that make sure there’s enough area on them for the switch arms.

Well. I can hear it click. I can see the endstop LED light up on the board. I think are 2 good indicators that the board received the endstop signal. The motor keeps spinning.

@vicious1 , I have wired the board exactly as per instructions on this site:

Z2 is the side with the rail tube, Z1 is the other side.

I have also marked the LEDs that light up when the gantry reaches the top:

Yes I am using the firmware from this site, The filename I downloaded was V1CNC_SkrPro_DualLR_2209-

I will try to make a video.

Try reflashing the board firmware, it takes 3 seconds.

When you try trigger by hand be sure to trigger twice while testing. The firmware hits the trigger, holds until the next one hits, then backs off both and re-homes both. (autoleveling)

Very funny things happen when the motors and endstops don’t line up. If you have them backwards, then one endstop will stop the other motor. Itay be you have the endstops right and theogors backwards?

That really doesn’t sound like what you are talking about. Don’t get mad at me :smile:. I just have to mention it, in case some of these things are red herrings.

In the marlin builds from the last few years, if M119 is correct, and your motors move the right way, and you have the correct motor associated with the correct endstop, then the firmware will be perfect. Ryan is right, software does the same thing every time.

Dunno, I tried to make a video of the problem, and then it suddenly worked fine 20-25 times in a row (of course). Now my phone is full of very amusing videos showing how everything works perfectly :smiley: I haven’t changed anything. I even reset the board to factory settings, still works fine.

The only thing I can think of is that I did power down the board recently, while previously I used to only reset it using the TFT reset button. I am not sure if I had any failures afterwards, been playing it for too long now.

@jeffeb3, that was the first thing that came to my mind as well, but when I click the endstop manually, I can kinda see that the corresponding leadscrew stops spinning. Well, one of them :slight_smile: Also tried swapping the endstop ports… dunno why, probably hoping for a miracle :smiley: Didn’t help much!

1 Like

OK it is back to weird mode. I captured it on video, but I can’t upload a video here. Now it fails almost every time.

Basically it went like this:

  • everything worked well for about 30 minutes with factory settings.
  • I increased velocity / accelleration values (around 2x)
  • endstops stopped working (both Z and Y axis)
  • I reset settings to factory defaults, including velocity etc
  • endstops still not working properly
  • I powered off the board (unplugged both 12v and USB) for 10+ seconds
  • everything seems to work fine again.

So it seems that powering off the board helps for some time.

No idea if adjusting velocity / acceleration has anything to do it or not.

Will try to reflash the firmware as well but somehow I doubt this will make a difference.

You really should not be changing these, but they should not affect it as the homing settings are different. Unless you are playing with the touch screen side then all bets are off.

Please do any testing in Marlin mode, or over USB with repetier. Touch mode is not the same as marlin mode it sends it’s own things that I can not control.

Those drivers with the giant heat sinks. Make sure they are not making contact with the pins, the TMC chips DO have endstop capabilities.

The pins are bent in the same way on all the drivers, including the ones with the oversized heatsinks. I also have some tape on the capacitors below them to make sure they are not touching the pins directly.

The issue happens on Y axis sometimes as well, which is connected to the regular 2209v1.2 driver.

I was using marlin mode all the time.

It seems to me as if changing settings somehow messes up the board memory and it starts this weird behavior. Will do some more tests.

Did some more homing tests.

Between each home command I did G0 X50 Y50 Z150 to move the gantry away from the endstops.

After fresh booting a cold board in the morning:

  • tests: 10
  • success: 7
  • fail: 3 (2xZ1, 1xZ2)

After reflashing firmware without powering down the board:

  • tests: 10
  • success: 0
  • fail: 10 (3 resolved on its own after clicking and making noise for some seconds, 7 times had to reset)

After power down for 10+ seconds:

  • tests: 10
  • success: 0
  • fail: 10 (6 resets, 4 resolved on its own but didn’t have proper home position)

Sometimes it looks as if the machine has homed properly (only a small click on one of the leadscrews in the 2nd phase, then goes on with homing), but the fact that the leadscrew clicks means that the motor didn’t stop on time and the homing position is inaccurate.

The Z axis fails more often than Y, but this is probably because Z is homed first. Sometimes Z homes fine, and then Y axis fails.

Never had this issue on X axis yet, but it only has one endstop.

I measured the voltage on the board terminals during homing, seems to be OK (12.19V)

Moving the drivers around has no effect.

Switching from 12V power to USB power also no effect.

I have a feeling I might need to buy yet another SKR Pro :confused:

Since your are doing science, I would park the machine at the endstops (triggered) and run M119 a bunch of times to see it it is always triggered.

None of this makes sense.