Temperature value odd in Repetier with 100 Ohm resistor

I have the Arduino/ramps board from the store here along with the resistor (100 Ohms, brown/black/brown/gold) and it has the Marlin firmware that Ryan pre-installed.

In Repetier I can connect just fine, but the temperature reading seems odd. It reads 570.10C. Looking at the tables, it should read somewhere around 210 or so.

Any ideas? I may just disable the thermistor since I’m doing a router but still…

Screenshot of the temp gauge.


Can you put up a screenshot of your whole repetier screen.
You put that resistor across terminal t0?

Yes, the resistor is across T0. It reads -27.00C when it’s not there.

Screenshot of whole Repetier screen…

Try flashing this one. https://www.v1engineering.com/wp-content/uploads/2015/05/Marlin_16_32_083015_THERM.zip

How long ago did you get this from me, have you flashed other firmware since you received it?

I bought it about a week ago. I haven’t flashed it ever. Just connected it a couple days ago. I’m uploading “Marlin_16_32_083015_THERM.ino” now.

Ok - I uploaded it and in Repetier it reads a little over 9C with the resistor installed and about 500C without. And yes, I checked that - it reads much hotter with no resistor.

It should work when it reads 9C. Does it work? sounds like your resistor is off a bit.

I checked the resistor: 99.2 Ohms.

Without the resistor it over temps. I can install the resistor and reset with an M999 code and it appears to work ok. I can “turn on” the extruder (there is no extruder, or even power to the RAMPS board, just the Arduino).

I see in Configuration.h the following…

#define TEMP_SENSOR_0 -1
#define TEMP_SENSOR_1 -1
#define TEMP_SENSOR_2 0

I believe the 0 values mean that the sensor doesn’t exist. The -1 values refer to a thermocouple. i.e.,
//// Temperature sensor settings:
// -2 is thermocouple with MAX6675 (only for sensor 0)
// -1 is thermocouple with AD595
// 0 is not used
// 1 is 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
// 2 is 200k thermistor - ATC Semitec 204GT-2 (4.7k pullup)

I think I read that you can just disable the sensor by putting 0 for all of them and that you like to just use the resistor to keep the option for printing without having to reflash the firmware. I’m going to try a different value - one for a thermistor.

It does not matter what the temp says as long as you don’t get the error. So now you can use it. Problem solved.

As for the rest of that, yes you can turn the temps off but I have never done it so I have no Idea if there are other things that need to be done. The normal firmware uses thermistor #11 for the 100ohm, or the mk8 style extruders. The firmware I linked for you works with higher value resistors normally. I should have the value for sensor 1 at 0…missed that one in all my firmware, but it has zero effect I use the one from the site myself.

I have no Idea why yours is acting funny I test every board with a 100ohm resistor so it did work with one.

I’m probably getting ahead of myself anyway. The power plug you sent me should be here today so I’ll be able to connect my motors and make them turn. I’m still printing the mechanicals. I found the models to be a bit too tight so I scaled them up by 2% and they fit my conduit much better - but it means reprinting several of them. Lots of fun though! Thanks again for the support.

They are made tight intentionally they should be great unless you are printing with something other than PLA. PLA tends to hold tolerances very well. Everything else distorts.

2% might make things bad in the center piece or loose everywhere. Be careful.

The middle ends were super tight on the conduit but after scaling they fit really nice. And the roller-f that I built cracked when I shoved the conduit through. So I printed it scaled up and since I wrote last, I put it together - well, it’s way too loose. I just built up another of the original sized ones and while a bit tight, it still works pretty well. I think as the galvanizing on the conduit flattens out it’ll be just right. I did have to remodel the z motor mount though. The conduit holes were so tight I couldn’t get them on, but the nema 17 holes were just right. Might have something to do with my printer though. Either way, I’m working through all the parts bit by bit. =)

Are you using PLA?

You should have all the bolts loose before you put the conduit in then snug them up a bit. I am guessing you put it together and tried to put them on tight?

I’m using ABS. And yes, I tightened everything up and shoved it onto the conduit. I’ll try doing it loose, but there’s not a lot of slop in the bolt holes. Might be just enough though.

ABS is the problem, dimension will change kind of randomly through shrinkage.

Found the problem, one of the bags of resistors is 100 ohms, needs to be 100k ohms.
Sorry the other firmware should work. I’ll update it soon and put it on the homepage shortly.

Hi, i am new here and now in the learning stage of the system.
can you please share your whole setup details here with schematics?
What are the specifications for the Arduino/Ryan board and the ryan firmware?

Assembly, https://www.v1engineering.com/assembly/
Firmware for the ramps, https://www.v1engineering.com/marlin-firmware/